cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aki Yoshida <elak...@googlemail.com>
Subject Re: JMX enabling in CXF 2.2.6
Date Mon, 23 Apr 2012 08:16:56 GMT
Hi,
there was a bug CXF-4170 that got into 2.5.2 when the code was changed
to solve another issue and also to add a simpler configuration option.

This problem caused the bean properties to incorrectly set when the
bus property is not set as the first entry within its bean
configuration (i.e., . when the InstrumentationManagerImpl bean is
directly configured).

To avoid this problem in 2.5.2, you need to move the bus property at
the top. Alternatively,  you can also configure the instrumentation
manager bean using the bus properties, as shown in the online page:

http://cxf.apache.org/docs/jmx-management.html

regards, aki

2012/4/23 nsmith9334 <nsmith9334@gmail.com>:
> Hi ,
>
> I am trying to enable JMX for CXF 2.5.2 and I seem to have encountered the
> same problem as above.
> I was able to successfully connect to the server using JConsole but I do not
> see any CXF MBeans.
>
> Based on one of the solutions discussed above, I tried to create a new
> connection to the JConsole using the JMX URL and username/passsword
> (cxf/cxf) and I was unable to get the JConsole CXF Mbeans.
>
> Any pointers as to how I can solve this issue?
>
>
> --
> View this message in context: http://cxf.547215.n5.nabble.com/JMX-enabling-in-CXF-2-2-6-tp577074p5658219.html
> Sent from the cxf-dev mailing list archive at Nabble.com.

Mime
View raw message