cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carlos Rodríguez Fernández <carlosrodrifernan...@live.com>
Subject Fixing WSDLValidator Tool
Date Thu, 22 Mar 2012 20:47:33 GMT

Hello everyone,This is Carlos. I'm having some free time and I'm trying to contribute to this
project fixing some bugs.Well, the first thing I did was downloading the whole trunk and running
some test. I found that the Command Line Tools Validator module does not pass one test related
to the detection of the error WSI-BP-1.0 R2726 because the validator detects another error
before (R2205).
The problem is because of the inputted wsdl. The fault messages should be defined with an
element instead of a type because their style is "document" by default. I fixed that creating
another WSDL without that issue and now the test passes and the validator detects the R2726
error successfully. Attached you can find the new wsdl to put in resources dir and below the
needed change in the code of the WSDLValidationTest file.
 @Test    public void testWSIBPR2726() throws Exception {        String[] args = new String[]
{"-verbose",                                      getLocation("/validator_wsdl/jms_test_R2726.wsdl")};
    // <-- the new file.        WSDLValidator.main(args);        assertTrue(getStdErr().indexOf("WSI-BP-1.0
R2726") > -1);    }
Do you want me guys to open an issue for this and attach a patch?
By the way, a minor spelling mistake in the Architecture Guide "can used" -> "can be used"??
:).
Regards,C. 		 	   		  
Mime
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message