cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Kulp <dk...@apache.org>
Subject Re: CXF generates badly formated services WSDL
Date Wed, 21 Mar 2012 15:26:52 GMT
On Wednesday, March 21, 2012 04:11:32 PM Sven Bendel wrote:
> Well, the file we talk about is fetched from `
> http://www.example.com:8081/TestWS/services?wsdl` which should return an
> WSDL, shouldn't it? 

Maybe not.  NORMALLY with cxf, all GET requests to 
http://www.example.com:8081/TestWS/services would return the services list 
page, not a wsdl.      Easy check is to point your browser at that URL and 
see what you get.   

Dan

> And there is a service deployed on the server. It runs
> quite well and responds without any problems when called from Eclipse's
> Web Service Explorer.
> 
> 2012/3/21 Daniel Kulp <dkulp@apache.org>
> 
> > On Tuesday, March 20, 2012 10:18:27 AM Sven Bendel wrote:
> > > I just found a bug in the current CXF release. Filed it under
> > 
> > http://stackoverflow.com/questions/9772857/webserver-generates-badly-for
> > ma> 
> > > ted-services-wsdl
> > > 
> > > and got the tip to share it with this mailing list. Can you confirm
> > > this
> > > is a bug?
> > 
> > Is there an actual service deployed on /services?   That's usually for
> > the service list page which would NOT be a wsdl.  That would be pure
> > HTML which is what looks like is being returned.
> > 
> > 
> > 
> > --
> > Daniel Kulp
> > dkulp@apache.org - http://dankulp.com/blog
> > Talend Community Coder - http://coders.talend.com
-- 
Daniel Kulp
dkulp@apache.org - http://dankulp.com/blog
Talend Community Coder - http://coders.talend.com


Mime
View raw message