cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sergey Beryozkin <sberyoz...@gmail.com>
Subject Re: Upgrading from 2.1.4 to 2.1.9
Date Wed, 23 Nov 2011 14:23:39 GMT

On 23/11/11 14:17, matiou wrote:
> Hi Dan,
>
> Thank you for your fast reply.
>
> Daniel  Kulp wrote
>>
>> The error makes it sound like there is an XML issue. Can you post the xml
>> configuration ?
> Here is the xml configuration file, which is pretty light (and works in
> 2.1.4) :
> <?xml version="1.0" encoding="UTF-8"?>
> <beans xmlns="http://www.springframework.org/schema/beans"
>    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>    xmlns:sec="http://cxf.apache.org/configuration/security"
>    xmlns:http="http://cxf.apache.org/transports/http/configuration"
>    xmlns:jaxws="http://java.sun.com/xml/ns/jaxws"
>    xmlns:wsa="http://cxf.apache.org/ws/addressing"
>    xmlns:cxf="http://cxf.apache.org/core"
>
>     xsi:schemaLocation="http://cxf.apache.org/core
>      				   http://cxf.apache.org/schemas/core.xsd
> 					   http://cxf.apache.org/configuration/security
> 					   http://cxf.apache.org/schemas/configuration/security.xsd
> 					   http://cxf.apache.org/transports/http/configuration
> 					   http://cxf.apache.org/schemas/configuration/http-conf.xsd
> 					   http://www.springframework.org/schema/beans
> 					   http://www.springframework.org/schema/beans/spring-beans-2.0.xsd">
>
>
> 	<http:conduit name="*.http-conduit">
> 		<http:client AutoRedirect="true" Connection="Keep-Alive"
> ConnectionTimeout="6000" ReceiveTimeout="6000" CacheControl="no-cache"
> AllowChunking="false" />
> 	</http:conduit>
> </beans>
>
>
> Daniel  Kulp wrote
>>
>> You can also try adding the namespaces needed to the http-conduit element.
>> That MAY help.
>>
> What's the namespaces you are talking about ? I don't see any mention of
> namespace needed in the stackstrace.
>

something like that I guess

<http:conduit 
name="{http://example.com/}HelloWorldServicePort.http-conduit">


Sergey

>


> Daniel  Kulp wrote
>> It almost sounds like you aren't picking up woodstox, but I'm not really
>> sure. 2.1.9 was still long enough ago that I'm not sure what the state of
>> everything was. I'd definitely suggest up
>> dating to 2.5.0 if possible and trying to see if that fixes things.
>>
> OK, I'll try it, hoping there will not be migration problem
>
> Thanks, matiou
>
> --
> View this message in context: http://cxf.547215.n5.nabble.com/Upgrading-from-2-1-4-to-2-1-9-tp5009968p5016781.html
> Sent from the cxf-dev mailing list archive at Nabble.com.


-- 
Sergey Beryozkin

http://sberyozkin.blogspot.com

Talend Community Coders
http://coders.talend.com/

Mime
View raw message