cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From matiou <m.roul...@gmail.com>
Subject Upgrading from 2.1.4 to 2.1.9
Date Mon, 21 Nov 2011 09:27:43 GMT
Hi everyone,

In order to call WebServices, I'm using cxf-api and cxf-rt-transports-http
2.1.4 and all is working fine.

Recently I have to pass through a proxy server, so, after a little search I
found ProxyAuthorizationPolicy(user & pwd) and HTTPClientPolicy (server &
port) which could do the rights things. But even if I fill password &
username in ProxyAuthorizationPolicy object, I obtained an 407 Proxy
Authentication Required.

Unfortunately, it seems It was the following issue for proxy authentication
with ssl (my case) : https://issues.apache.org/jira/browse/CXF-2223.

I downloaded 2.1.9 where the issue is normally fixed.
And now, with the same code than previously, I obtain the error below, which
happens on the code line : HTTPConduit conduit = (HTTPConduit)
client.getConduit();

StackTrace :
Error creating bean with name '*.http-conduit': Cannot create inner bean
'(inner bean)' of type [org.apache.cxf.configuration.spring.JAXBBeanFactory]
while setting bean property 'client';
	nested exception is
org.springframework.beans.factory.BeanCreationException: Error creating bean
with name '(inner bean)': Instantiation of bean failed;
	nested exception is
org.springframework.beans.factory.BeanDefinitionStoreException: Factory
method [public static java.lang.Object
org.apache.cxf.configuration.spring.JAXBBeanFactory.createJAXBBean(javax.xml.bind.JAXBContext,java.lang.String,java.lang.Class)]
threw exception;
	nested exception is java.lang.RuntimeException:
javax.xml.bind.UnmarshalException - with linked exception:
[javax.xml.stream.XMLStreamException: ParseError at [row,col]:[1,219]
Message:
http://www.w3.org/TR/1999/REC-xml-names-19990114#ElementPrefixUnbound?http&http:client]

Thanks in advance for your reply

matiou

Environment :
- jdk16u24
- eclipse indigo
- cxf-api-2.19, cxf-rt-frontend-simple-2.19, cxf-rt-transports-http-2.1.9
- spring-core-2.5.6, spring-beans-2.5.6, spring-context-2.5.6


--
View this message in context: http://cxf.547215.n5.nabble.com/Upgrading-from-2-1-4-to-2-1-9-tp5009968p5009968.html
Sent from the cxf-dev mailing list archive at Nabble.com.

Mime
View raw message