cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Kulp <dk...@apache.org>
Subject Re: Any idea why ws.rm.ServerPersistenceTest fails from time to time?
Date Fri, 22 Apr 2011 10:53:38 GMT
On Friday 22 April 2011 1:20:33 AM Dennis Sosnoski wrote:
> Sounds great, Aki. Why don't you go ahead and commit your fix?

Because with the minotaur hardware upgrades this week, the infra folks haven't 
done any accont creations this week yet.  :-(

Dan


>    - Dennis
> 
> On 04/22/2011 10:20 AM, Aki Yoshida wrote:
> > Hi,
> > this is an old issue discussed in
> > http://cxf.547215.n5.nabble.com/Any-idea-why-ws-rm-ServerPersistenceTest-
> > fails-from-time-to-time-td3298549.html and tracked in CXF-3179.
> > 
> > I also thought the cause to be some timing issue.
> > I needed to have this test case to succeed more reliably.
> > But sometimes even with a long waiting time, the first part of the
> > test already failed.
> > So, I looked into it and found another problem.
> > 
> > This test is using the message loss simulator in the server's outbound
> > chain. That means, in the first part of the test, among the three
> > greeter replies from the server, the second one should get lost.
> > However, as the server is sending out responses concurrently and the
> > message loss simulator's operation isn't synchronized, I observed that
> > sometimes two successive messages were getting lost. And when this
> > situation happens, the first part of the test will be failing.
> > 
> > When I made the MessageLossSimulator's handleMessage method
> > synchronized to avoid this problem, this problem disappeared and it
> > seems the waiting time can even be made shorter.
> > 
> > 
> > Regards, Aki

-- 
Daniel Kulp
dkulp@apache.org
http://dankulp.com/blog
Talend - http://www.talend.com

Mime
View raw message