cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dennis Sosnoski <...@sosnoski.com>
Subject Build problem
Date Fri, 11 Mar 2011 04:15:43 GMT
I've been having a problem in the build for the last several days. This
occurs in systest/jaxws:

FAILURE!
testJAXBObjectPAYLOAD(org.apache.cxf.systest.dispatch.DispatchClientServerTest) 
Time elapsed: 10.453 sec  <<< ERROR!
java.util.concurrent.TimeoutException: Timeout Exceeded
        at
org.apache.cxf.endpoint.ClientCallback.get(ClientCallback.java:166)
        at
org.apache.cxf.jaxws.JaxwsResponseCallback.get(JaxwsResponseCallback.java:54)
        at
org.apache.cxf.systest.dispatch.DispatchClientServerTest.testJAXBObjectPAYLOAD(DispatchClientServerTest.java:508)

I've dug into the code enough to see that the socket receive timeout is
being set on the connection, so I'm wondering if it's a problem with the
socket handling on my system. I'm running OpenSuse 11.3, and have tried
both Java 5 and 6.

Has anyone else encountered this problem? Or have any suggestions how to
handle it, aside from just disabling the test for my builds?

Thanks,

  - Dennis

-- 

Dennis M. Sosnoski
Java SOA and Web Services Consulting <http://www.sosnoski.com/consult.html>
Axis2/CXF/Metro SOA and Web Services Training
<http://www.sosnoski.com/training.html>
Web Services Jump-Start <http://www.sosnoski.com/jumpstart.html>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message