cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dennis Sosnoski <...@sosnoski.com>
Subject Build failure
Date Wed, 09 Feb 2011 23:17:07 GMT
I'm getting a test failure with Simple Frontend:

-------------------------------------------------------
 T E S T S
-------------------------------------------------------
Running org.apache.cxf.frontend.soap.SoapBindingSelectionTest
Tests run: 1, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 1.263 sec
Running org.apache.cxf.frontend.spring.ClientServerTest
Tests run: 1, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 0.463 sec
Running org.apache.cxf.frontend.spring.SpringBeansTest
Tests run: 2, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 0.607 sec
Running org.apache.cxf.service.factory.RountripTest
Tests run: 2, Failures: 0, Errors: 1, Skipped: 0, Time elapsed: 0.347
sec <<< FAILURE!
testServerFactoryBean(org.apache.cxf.service.factory.RountripTest)  Time
elapsed: 0.076 sec  <<< ERROR!
java.lang.IllegalStateException: Local destination does not have a
MessageObserver on address http://localhost/Hello
        at
org.apache.cxf.transport.local.LocalConduit.dispatchViaPipe(LocalConduit.java:114)
        at
org.apache.cxf.transport.local.LocalConduit.prepare(LocalConduit.java:59)
        at
org.apache.cxf.interceptor.MessageSenderInterceptor.handleMessage(MessageSenderInterceptor.java:46)
        at
org.apache.cxf.phase.PhaseInterceptorChain.doIntercept(PhaseInterceptorChain.java:255)
        at org.apache.cxf.endpoint.ClientImpl.invoke(ClientImpl.java:516)
        at org.apache.cxf.endpoint.ClientImpl.invoke(ClientImpl.java:313)
        at org.apache.cxf.endpoint.ClientImpl.invoke(ClientImpl.java:265)
        at
org.apache.cxf.frontend.ClientProxy.invokeSync(ClientProxy.java:73)
        at org.apache.cxf.frontend.ClientProxy.invoke(ClientProxy.java:68)
        ...

Running org.apache.cxf.service.factory.ServerFactoryTest
Tests run: 3, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 0.413 sec
Running org.apache.cxf.service.factory.ClientFactoryBeanTest
Tests run: 2, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 0.102 sec
Running org.apache.cxf.service.factory.ReflectionServiceFactoryTest
Tests run: 4, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 0.185 sec
Running org.apache.cxf.service.stax.StaxDatabindingTest
Tests run: 2, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 0.111 sec

Results :

Tests in error:
  testServerFactoryBean(org.apache.cxf.service.factory.RountripTest)

Tests run: 17, Failures: 0, Errors: 1, Skipped: 0

Any suggestions? This is with the latest code, but I also saw the same
problem when I tried to build a couple of days ago with the then-latest
code.

I'm running on Linux, using Sun/Oracle 1.5.0_15 and 1.6.0_10 JVMs.

  - Dennis

-- 

Dennis M. Sosnoski
Java SOA and Web Services Consulting <http://www.sosnoski.com/consult.html>
Axis2/CXF/Metro SOA and Web Services Training
<http://www.sosnoski.com/training.html>
Web Services Jump-Start <http://www.sosnoski.com/jumpstart.html>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message