cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ate Douma <...@douma.nu>
Subject Re: Intermediate build issues on the trunk
Date Thu, 30 Sep 2010 13:34:35 GMT
On 30/09/10 15:19, Daniel Kulp wrote:
>
> Can I ask some details?
>
> Maven version:
> Java version (full version string):
> 32/64 bit:
> Value of MAVEN_OPTS env variable:
> OS (and version):

- maven 2.2.1
- java 1.6.0_20-b02 (32 bits)
- MAVEN_OPTS=-Xmx512m -XX:MaxPermSize=256m
- Ubuntu 10.04.1, 2.6.32-24-generic-pae

Ate

>
> I haven't run into this in a while.  :-(
>
> Dan
>
>
>
> On Thursday 30 September 2010 8:29:23 am Richard Opalka wrote:
>>    I'm facing this issue each time I build CXF trunk.
>> The trick that works for me is: build twice :D
>> Second build run is usually successful on my machine.
>>
>> Rio
>>
>> PS: I agree it's weird.
>>
>> On 09/30/2010 02:10 PM, Ate Douma wrote:
>>> On 30/09/10 13:01, Sergey Beryozkin wrote:
>>>> Hi
>>>>
>>>> Ate Douma has reported the following build issues on the trunk :
>>>>
>>>> [...]
>>>> /cxf-2.3.0-SNAPSHOT/api/src/main/java/org/apache/cxf/wsdl/TExtensibility
>>>> ElementImpl.java:
>>>>
>>>> [31,12] cannot find symbol
>>>> symbol: class TExtensibilityElement
>>>> extends TExtensibilityElement
>>>>
>>>> Shortly above this error is another suspicious error logged by
>>>> cxf-xjc:xsdtojava:
>>>> [INFO] [cxf-xjc:xsdtojava {execution: generate-sources}]
>>>> [ERROR] The declaration for the entity "ContentType" must end with '>'.
>>>> line 81 of http://www.w3.org/TR/1999/REC-html401-19991224/strict.dtd
>>>>
>>>> See CXF-2997 for more details.
>>>>
>>>> I've seen these build issues too, and usually I 'fix' them by
>>>> removing a cxf
>>>> tree from the local maven repo.
>>>> Has anyone seen these errors as well ?
>>>
>>> Sergey,
>>>
>>> I just tried your hint of removing cxf tree from local repo. But that
>>> didn't work for me the first time either.
>>> However, when I rebuild once more, it all of a sudden worked.
>>> To validate this I did another clean checkout of cxf trunk, removed
>>> cxf tree once more from local repo and build again.
>>> Now, it worked the first time.
>>> Weird stuff ...
>>>
>>> One suspicious thing I noticed while also building cxf-xjc trunk
>>> myself (as I suspected the remote snapshot repository might be
>>> outdated) was that it showed to have a dependency on the
>>> cxf-java2ws-plugin from cxf main (downloading it from the remote
>>> snapshot repository).
>>> But as cxf main itself in turn is depending on cxf-xjc, this seems to
>>> indicate a circular dependency between the two.
>>> If that is anywhere related to the above issue I have no idea, but
>>> with such circular (SNAPSHOT) dependencies you can of course end up
>>> with using an outdated version of either one of them during the build.
>>>
>>> Regards,
>>>
>>> Ate
>>>
>>>> thanks, Sergey
>


Mime
View raw message