cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sergey Beryozkin <sberyoz...@gmail.com>
Subject Re: Regressions in WS-Trust 10 interopfest demo
Date Thu, 19 Aug 2010 12:13:53 GMT
All of those NoSuchMethodError exceptions have been probably caused by the
fact I was building sandbox projects depending on outdated 2.3-SNAPSHOT
views, so after removing the cxf artifacts from the maven repo I can the
exceptions gone.

However, it does appear we have a regression in scenarios 9 and 10 :

Scenario_9_IssuedTokenForCertificate_MutualCertificate11: Exception:
javax.xml.ws.soap.SOAPFaultException: An error occurred when verifying
security for the message.
Scenario_10_IssuedTokenForCertificateSecureConversation_MutualCertificate11:
Exception: javax.xml.ws.soap.SOAPFaultException: An error occurred when
verifying security for the message.

Has anyone worked in this area recently ? I'm going to start looking into it
as well...

cheers, Sergey

On Thu, Aug 19, 2010 at 11:55 AM, Sergey Beryozkin <sberyozkin@gmail.com>wrote:

> Hi
>
> I'm seeing all sorts of problems when running
> samples/ws_security/interopfest/wstrust10, both in 2.3.0-SNAPSHOT and on
> 2.2.x.
> I did run the demo last week and it worked for me but today it is just all
> failing.
>
> In 2.3.0-SNAPSHOT I had to update the version of maven-ant-run plugin to
> 1.4 just to get the build working, but besides that I'm seeingucuch
> some strange errors like
>
> java.lang.NoSuchMethodError:
> org.apache.cxf.ws.security.trust.STSClient.setPolicy(Lorg/apache/neethi/Policy;)V
>     at
> org.apache.cxf.ws.security.policy.interceptors.SecureConversationTokenInterceptorProvider.setupClient(SecureConversationTokenInterceptorProvider.java:167)
>
> even though I can see STSClient.setPolicy(Object policy) method...
>
> In 2.2.x, the problem is that CXF version gets resolved to 2.3.0-SNAPSHOT,
> setting the version to 2.2.11-SNAPSHOT results in the async binding test
> failures.
>
> Can someone please give it a try and confirm it is just not me only ? Now,
> assuming there're regressions, I'd have to start investigating. Given that
> I'm a bit raw so to say in this area, any help will be appreciated
>
> thanks, Sergey
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message