cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Muhammad Sheraz Siddiqi" <mshe...@folio3.com>
Subject RE: JAX-RS not working
Date Wed, 18 Aug 2010 09:21:52 GMT
I was able to solve my problem. The problem was I did not include "Spring
context listener". Once I included that in web.xml everything is working
fine now.

Thank you for your response.

-Attari

-----Original Message-----
From: Sergey Beryozkin [mailto:sberyozkin@gmail.com] 
Sent: Tuesday, August 17, 2010 10:53 AM
To: dev@cxf.apache.org
Subject: Re: JAX-RS not working

Hi

At least in this message, the beans.xml is definitely wrong, there's a typo,
jaxws:endpoint/@implementor refers to
jaxrs:server as opposed to helloBean...

the exception message may also help...

cheers, Sergey

On Mon, Aug 16, 2010 at 12:27 PM, Muhammad Sheraz Siddiqi <
msheraz@folio3.com> wrote:

> Hi
>
>
>
> I am unable to deploy JAX-RS and JAX-WS web services in Tomcat/JBoss.
>
>
>
> I believe there is something wrong with the beans.xml file.
>
>
>
> <jaxws:endpoint id="hello"  implementor="#helloRest"  address="/Hello"/>
>
>
>
>
>  <jaxrs:server id="helloRest" address="/HelloRest">
>
>    <jaxrs:serviceBeans >
>
>      <ref bean="helloBean" />
>
>    </jaxrs:serviceBeans>
>
>  </jaxrs:server>
>
>
>
>  <bean id="helloBean" class="com.bn.ws.service.HelloRest" />
>
>
>
> In the <jaxws:endpoint> If I replace implementor="#helloRest" with
> implementorClass="com.bn.ws.service.HelloRest" it starts working.
>
> But I am not sure the same equivalent for <jaxrs:server>.
>
>
>
> Any help please ?
>
>
>
> -Attari
>
>



Mime
View raw message