cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eoghan Glynn <eogl...@gmail.com>
Subject Re: DOSGI: Update to CXF 2.2.9
Date Mon, 19 Jul 2010 22:44:35 GMT
OK, fair enough.

One other small issue with the attach-sources in cxf-dosgi-remote-service-
admin-interfaces being in the wrong phase (leaving the sources jar
unsigned).

Now fixed, so we should be good to go with this.

I'll go ahead and call the release vote ...

/Eoghan


On 19 July 2010 17:33, <davidb@apache.org> wrote:

> Hi Eoghan,
>
> All I can say is that the system tests always work fine on my machine
> and that they also work fine on Hudson...
> http://hudson.zones.apache.org/hudson/view/CXF/job/CXF-DOSGi/
>
> Having said that, it's always a little tricky to get system tests
> right for all machines as there are so many things at play. Port
> numbers, timing, processor architecture, platform, they can all have
> an impact.
> I'm pretty sure the functionality tested by the system tests works,
> although the tests themselves might need a little tweaking to run on
> all machines (including yours - if you have any tips I would love to
> hear them :)
>
> Cheers,
>
> David
>
> On 19 July 2010 12:35, Eoghan Glynn <eoglynn@gmail.com> wrote:
> >
> > Hi David,
> >
> >> This exception happens when the remote service doesn't appear within
> >> the timeout... Any chance of running it again and see if it still
> >> fails?
> >
> > OK, I ran the build a few more times and didn't see the same failure, so
> > lets put that one down to a once-off aberration.
> >
> > However, when cutting the release I'm seeing an apparent hang in
> > org.apache.cxf.dosgi.systests2.single.TestImportService. I've attached
> the
> > tail of the console output so you can see if anything rings a bell there.
> >
> > For the moment the release is in limbo, i.e. the poms are updated, the
> tag
> > is laid down and the artifacts partially uploaded to the staging area in
> > Nexus. The upload doesn't look like its going to complete, seeing as the
> > test has been hung for the last half hour, so either way I'll be killing
> > that. However if you need to get any further fixes in, let me know and
> I'll
> > also roll back the changes in SVN and start from scratch next time.
> >
> > If on the other hand you're confident about the integrity of the tests, I
> > could potentially re-run the release with
> -Darguments=-Dmaven.test.skip=true
> > but I'm leery about doing so unless we're fairly happy that I'm seeing a
> > phantom issue here.
> >
> > Cheers,
> > Eoghan
> >
> >
> > On 19 July 2010 10:30, <davidb@apache.org> wrote:
> >>
> >> Hi Eoghan,
> >>
> >> On 17 July 2010 12:59, Eoghan Glynn <eoglynn@gmail.com> wrote:
> >> >> Eoghan would you have some cycles?
> >> >
> >> > Yeah.
> >>
> >> Excellent!
> >>
> >> > A couple of things before I go ahead and cut the release:
> >> >
> >> > - can you update the release notes[1] with a summary of what's new in
> >> > this
> >> > release?
> >>
> >> Done.
> >>
> >> > - does this TimeoutException[2] in
> >> > TestExportService.testAccessEndpoint()
> >> > ring any bells?
> >>
> >> Not really, to be honest... It always passes for me :) It also passed
> >> on the last hudson run:
> >>
> >>
> http://hudson.zones.apache.org/hudson/view/CXF/job/CXF-DOSGi/org.apache.cxf.dosgi.systests$cxf-dosgi-ri-systests2-singlebundle/180/testReport/org.apache.cxf.dosgi.systests2.single/TestExportService/
> >>
> >> This exception happens when the remote service doesn't appear within
> >> the timeout... Any chance of running it again and see if it still
> >> fails?
> >>
> >> Best regards,
> >>
> >> David
> >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message