cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Florent BENOIT <Florent.BEN...@ow2.org>
Subject CXF 2.2.x OSGi Bundle / import on javax.servlet.*
Date Fri, 02 Jul 2010 10:03:41 GMT
    Hi,

I'm facing a problem with the CXF 2.2.9 Bundle and Servlet API in OSGi mode
If javax.servlet package is exported in 3.0.0 version, the CXF bundle 
won't start

This is because, in the MANIFEST generated by the following pom.xml 
[https://svn.apache.org/repos/asf/cxf/branches/2.2.x-fixes/distribution/bundle/all/pom.xml

], there is the following code:
/javax.servlet.*;version="[0.0,3)";resolution:=optional,/

Which means that javax.servlet package exported in 3.0 version won't be 
accepted
Is there a reason to use 3 ? or maybe you could switch to
/javax.servlet.*;version="[0.0,4)";resolution:=optional,/
in order to accept javax.servlet exported in 3.0 version or remove the 
versioning number ?

I may open an issue on the jira tracker about this.

Note that this is the same case for the trunk version : 
https://svn.apache.org/repos/asf/cxf/trunk/distribution/bundle/all/pom.xml

Regards,

Florent


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message