cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dennis Sosnoski <...@sosnoski.com>
Subject Re: [JiBX DataBinding] An issue when feeding the XMLStreamReader to JiBX framework
Date Tue, 29 Jun 2010 20:11:49 GMT
Never mind, I think I found the issue. I've changed the 
StAXReaderWrapper code so that you should no longer need to call 
startTag() at all and have changed that back to a private method. Please 
try the latest 1.2.3-SNAPSHOT jars and verify that this now works.

Thanks again,

  - Dennis


Dennis Sosnoski wrote:
> Nilupa Bandara wrote:
>> On Sat, Jun 26, 2010 at 1:00 AM, Dennis Sosnoski <dms@sosnoski.com> 
>> wrote:
>> ...
>>  
>>> Nilupa, I've updated JiBX CVS with this change and posted new
>>> 1.2.3-SNAPSHOT jars to the maven1 repository at
>>> http://jibx.sourceforge.net/maven/jibx/jars/ Try adding the call to
>>> startTag() after constructing the StAXReaderWrapper, it should get 
>>> you past
>>> the problem.
>>>
>>>
>>>     
>> Hi,
>>
>> Still it gives an error even if  I call the startTag() after 
>> instantiating
>> the StAXReaderWrapper  object[1]. However if I call same method twice
>> startTag(), it works[2]
>>   
>
> It sounds like the code is somehow reading beyond the end of the 
> element you're having JiBX unmarshal, to the enclosing element end 
> tag. I don't know why this would be occurring.
>
> Can you send me the stack traces you get when (1) you don't call 
> wrapper.startTag() at all, and when (2) you just call it once? That 
> may help me determine what's going wrong.
>
> Thanks,
>
>  - Dennis
>

Mime
View raw message