cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexandros Karypidis <akary...@yahoo.gr>
Subject Re: move up to springframework 2.5.6?
Date Sat, 05 Dec 2009 10:52:03 GMT
Sorry to bring this up again, but apparently "camel-cxf" version 2.1.0 
has started pulling in spring 2.5.6 modules (including spring-jms). A 
lot of people are using Camel + CXF so I was wondering whether:

1) They should stick to older Camel versions
2) They can use Camel 2.1.0 as long as they override spring dependencies 
in their POMs to use 2.5.5
3) The "bug" can be fixed / worked around?

By the way, regarding (3), can someone provide more information on what 
the issue is? I wouldn't mind having a look at it to investigate.

Daniel Kulp wrote:
> On Wed November 4 2009 10:43:38 am Eamonn Dwyer wrote:
>   
>> Hi
>> is there a reason we are using version 2.5.5 of spring framework? I think
>>  servicemix and camel have already moved on up to 2.5.6, so would it be a
>>  good idea to upgrade to both stay in synch with them and also to avail of
>>  any bug fixes.
>>     
>
> Spring 2.5.6 has a "bug" in the JMS stuff that is resulting in stack traces 
> being printed out in several places when running out test suite.  We've more 
> or less stayed on 2.5.5 so that those stack traces aren't confused with real 
> errors.
>
>   


Mime
View raw message