cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From karypid <akary...@yahoo.gr>
Subject Re: Missing OM* classes
Date Tue, 01 Sep 2009 08:39:34 GMT

Ok, so I've added the dependency in cxf-api/pom.xml, which allowed
compilation to proceed:

		<dependency>
			<groupId>org.apache.ws.commons.axiom</groupId>
			<artifactId>axiom-impl</artifactId>
			<version>1.2.7</version>
		</dependency>

Is this an omission? I downloaded my local copy from:

http://svn.apache.org/repos/asf/cxf/tags/cxf-2.2.3

Is that not the official release tag?


karypid wrote:
> 
> Hi all,
> 
> I'm having a problems compiling  CXF 2.2.3. Very early, when it reaches 
> "Apache CXF API" it hits errors for missing the AXIOM classes:
> 
> [INFO] 
> ------------------------------------------------------------------------
> [INFO] Building Apache CXF API
> [INFO]    task-segment: [install]
> 
> ...
> 
> [INFO] Compiling 263 source files to 
> D:\aiq\jbossws\projects\cxf-2.2.3\api\target\classes
> [INFO] 
> ------------------------------------------------------------------------
> [ERROR] BUILD FAILURE
> [INFO] Compilation failure
> 
> could not parse error message: 
> org\apache\neethi\PolicyReference.java(org\apache\neethi:PolicyReference.java):35: 
> package org.apache.axiom.om does not exist
> import org.apache.axiom.om.OMElement;
>                           ^
> ...
> 

-- 
View this message in context: http://www.nabble.com/Missing-OM*-classes-tp25224076p25236469.html
Sent from the cxf-dev mailing list archive at Nabble.com.


Mime
View raw message