cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Krzysztof Malinowski" <kmali...@toya.net.pl>
Subject Re: Migration problem from Win to Unix
Date Wed, 27 May 2009 08:21:22 GMT
Thanks for response,

Of course, correct JBoss ver. 4.2.3
In order the second question, an address is set like this:

   JaxWsProxyFactoryBean jaxWsProxyFactoryBean = new JaxWsProxyFactoryBean();
   jaxWsProxyFactoryBean.setServiceClass(PodmiotySprzedazyServicePortType.class);
   jaxWsProxyFactoryBean.setAddress(wsAddressPs);
   
   jaxWsProxyFactoryBean.getOutInterceptors().add(wssOut);

actually is covered in String value: wsAddressPs
----- Original Message ----- 
From: "Alessio Soldano" <asoldano@redhat.com>
To: <dev@cxf.apache.org>
Sent: Tuesday, May 26, 2009 5:25 PM
Subject: Re: Migration problem from Win to Unix


> Hi,
> 
> Krzysztof Malinowski wrote:
>> Caused by: java.io.IOException: Illegal Protocol http for HTTPS
>> URLConnection Factory.
>>         at
>> org.apache.cxf.transport.https.HttpsURLConnectionFactory.createConnection(HttpsURLConnectionFactory.java:124)
>>         at
>> org.apache.cxf.transport.http.HTTPConduit.prepare(HTTPConduit.java:482)
>>         at
>> org.apache.cxf.interceptor.MessageSenderInterceptor.handleMessage(MessageSenderInterceptor.java:46)
>>         ... 43 more
>>
>> As I said, both server side is the same: the same JDK 1.6, JBoss 1.2.3. The
>> diference is, the first is on WinXP, the second on Unix (Sun Solaris)
>>
>> What is the reason of that, first is OK, second doesn't?
>>
>>   
> How are you setting the endpoint address / configuring the https usage? 
> I think seeing your jaxws cliend would help. It seems the url protocol 
> of the endpoint address is wrong.
> 
> P.S. is that *really* the jboss version you're using?
> 
> -- 
> Alessio Soldano
> Web Service Lead
> JBoss, a division of Red Hat
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message