cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Benson Margulies <bimargul...@gmail.com>
Subject Re: Sun StaX versus JAX-RS
Date Wed, 04 Mar 2009 11:53:29 GMT
You don't need jdk 1.6. This uses a maven depedency to get the parser
independently.

Yes, we'll find some way to spike the test if there's no solution.


On Wed, Mar 4, 2009 at 5:52 AM, Sergey Beryozkin <sberyozk@progress.com> wrote:
> Hi Benson
>
> I presume it's JDK 6 which needs to be used ? I'll try to look asap - I do
> need to close few issues raised recently against JAXRS plus do a bit of
> client api cleanup before 2.2 goes out. Can this test be disabled when run
> as part of the Psjsxp profile if it blocks you ? I'll try to look into this
> asap - but if it's indeed a bug/limitation in Axiom/Abdera then it won't be
> fixed before 2.2. anyway...
>
> Cheers, Sergey
> - Show quoted text -
>
>
>> Hello Department of Jax-RS:
>>
>> Dan and I have been working on supporting Sun's sjsxp, a stax
>> implementation built into newer JDK's. We've nearly got the whole
>> thing passing, save, significantly, for
>>
>> JAXRSAtomBookTest
>>
>> This fails inside of abdera/axiom complaining that it's trying to read
>> from a closed stream.
>>
>> This is probably going to wind around to a bug report for Abdera or
>> Axiom, but could I please pass the analysis over to the JAX-RS
>> politburo?
>>
>> To repro,
>>
>> mvn -Psjsxp
>>
>> --benson
>
>

Mime
View raw message