cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Willem Jiang <willem.ji...@gmail.com>
Subject Re: Failures of unit tests on 2.2 snapshot
Date Sat, 17 Jan 2009 05:16:55 GMT
Hi Andy,

Which OS are you using to run the tests ?
I got these failures in my Windows Vista box sometime.

Willem

amichalec wrote:
> Hi everybody,
> I am trying to make full build from sources taken from svn repo but I've
> found lot of failures in unit test in JAX-WS area:
> 
>   <testcase
> classname="org.apache.cxf.systest.ws.addr_feature.WSAClientServerTest"
> time="61.078" name="testCxfWsaFeature">
>     <error type="javax.xml.ws.soap.SOAPFaultException" message="Could not
> send Message.">javax.xml.ws.soap.SOAPFaultException: Could not send Message.
> 	at org.apache.cxf.jaxws.JaxWsClientProxy.invoke(JaxWsClientProxy.java:145)
> 	at $Proxy60.addNumbers(Unknown Source)
> ...
> 
>   <testcase classname="org.apache.cxf.systest.ws.rm.SequenceTest"
> time="65.469" name="testOnewayAnonymousAcks">
>     <error type="javax.xml.ws.soap.SOAPFaultException" message="Failed to
> send RM protocol message
> {http://schemas.xmlsoap.org/ws/2005/02/rm}CreateSequence.">javax.xml.ws.soap.SOAPFaultException:
> Failed to send RM protocol message
> {http://schemas.xmlsoap.org/ws/2005/02/rm}CreateSequence.
> 	at org.apache.cxf.jaxws.JaxWsClientProxy.invoke(JaxWsClientProxy.java:145)
> 	at $Proxy51.greetMeOneWay(Unknown Source)
> 
> ...
> 
> And some other issues like this one:
> 
>   <testcase classname="org.apache.cxf.systest.clustering.FailoverTest"
> time="0.546" name="testNoFailoverOnApplicationFault">
>     <error type="javax.xml.ws.soap.SOAPFaultException" message="Error
> reading XMLStreamReader.">javax.xml.ws.soap.SOAPFaultException: Error
> reading XMLStreamReader.
> 	at org.apache.cxf.jaxws.JaxWsClientProxy.invoke(JaxWsClientProxy.java:145)
> 	at $Proxy51.pingMe(Unknown Source)
> ...
> 	at org.apache.cxf.jaxws.JaxWsClientProxy.invoke(JaxWsClientProxy.java:124)
> 	... 28 more
> Caused by: com.ctc.wstx.exc.WstxUnexpectedCharException: Unexpected
> character &apos;5&apos; (code 53) in prolog; expected &apos;&lt;&apos;
>  at [row,col {unknown-source}]: [1,1]
> 	at
> com.ctc.wstx.sr.StreamScanner.throwUnexpectedChar(StreamScanner.java:648)
> 	at
> com.ctc.wstx.sr.BasicStreamReader.nextFromProlog(BasicStreamReader.java:2047)
> 
> 
> I wonder if tests should be running w/o errors or repo is in some transitive
> state.
> I was reading about some problems with networked tests of WS with some
> workaround but I cannot apply them. I want to experiment and focus more on
> JAX-RS code so any hints are appreciated e.g. how selectively run JAX-RS
> unit tests :)
> 
> cheers,
> andy.


Mime
View raw message