cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Kulp <dk...@apache.org>
Subject Re: unable to configure wsrm in cxf-2.1.2
Date Fri, 05 Dec 2008 22:23:56 GMT

I think the person that would know the most about this is out for a bit.  :-(

Have you looked at the ws_rm sample that we ship?  

Dan


On Thursday 27 November 2008 10:18:13 am Naresh Tallapelli wrote:
> Hi All,
>
> I am trying to configure reliable messaging through configuration file and
> through the code. But it was not working. I tried with cxf-2.0.4 and
> cxf-2.1.2 versions. Following is the configuration i tried to enable
> reliable messaging.
>
> <cxf:bus>
>     <cxf:features>
>     <cxf:logging />
>     <wsa:addressing />
>     <wsrm-mgr:reliableMessaging>
>     <wsrm-policy:RMAssertion>
>     <wsrm-policy:BaseRetransmissionInterval
>             Milliseconds="4000" />
>     <wsrm-policy:AcknowledgementInterval
>             Milliseconds="2000" />
>     </wsrm-policy:RMAssertion>
>     <wsrm-mgr:sourcePolicy>
>     <wsrm-mgr:sequenceTerminationPolicy maxLength="5" />
>     </wsrm-mgr:sourcePolicy>
>     <wsrm-mgr:destinationPolicy acceptOffers="false" />
>     <wsrm-mgr:store>
>     <ref bean="myStore" />
>     </wsrm-mgr:store>
>     </wsrm-mgr:reliableMessaging>
>     </cxf:features>
> </cxf:bus>
>
> I have tried all the configuration options specified in the following link
>
> http://cwiki.apache.org/CXF20DOC/wsrmconfiguration.html
>
> Can anyone able to configure wsrm in cxf?
>
> Could any one please send me the steps on how to enable reliable messaging
> in cxf-2.1.2 ? So that i can configure wsrm for my webservice.
>
> Thank you,
> Naresh



-- 
Daniel Kulp
dkulp@apache.org
http://dankulp.com/blog

Mime
View raw message