cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Naresh Tallapelli" <naresh.tallape...@gmail.com>
Subject unable to configure wsrm in cxf-2.1.2
Date Thu, 27 Nov 2008 15:18:13 GMT
Hi All,

I am trying to configure reliable messaging through configuration file and
through the code. But it was not working. I tried with cxf-2.0.4 and
cxf-2.1.2 versions. Following is the configuration i tried to enable
reliable messaging.

<cxf:bus>
    <cxf:features>
    <cxf:logging />
    <wsa:addressing />
    <wsrm-mgr:reliableMessaging>
    <wsrm-policy:RMAssertion>
    <wsrm-policy:BaseRetransmissionInterval
            Milliseconds="4000" />
    <wsrm-policy:AcknowledgementInterval
            Milliseconds="2000" />
    </wsrm-policy:RMAssertion>
    <wsrm-mgr:sourcePolicy>
    <wsrm-mgr:sequenceTerminationPolicy maxLength="5" />
    </wsrm-mgr:sourcePolicy>
    <wsrm-mgr:destinationPolicy acceptOffers="false" />
    <wsrm-mgr:store>
    <ref bean="myStore" />
    </wsrm-mgr:store>
    </wsrm-mgr:reliableMessaging>
    </cxf:features>
</cxf:bus>

I have tried all the configuration options specified in the following link

http://cwiki.apache.org/CXF20DOC/wsrmconfiguration.html

Can anyone able to configure wsrm in cxf?

Could any one please send me the steps on how to enable reliable messaging
in cxf-2.1.2 ? So that i can configure wsrm for my webservice.

Thank you,
Naresh

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message