cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Freeman Fang <freeman.f...@gmail.com>
Subject Re: Problems doing my first CXF Web Service
Date Fri, 25 Jan 2008 07:55:28 GMT
looks like the cxf-rt-frontend-jaxws.jar is not in your project 
classpath, did you follow the instruction step by step especially the 
"Adding CXF runtime in Eclipse"?

Best Regards

Freeman

pjmorce wrote:
> Hello
>
> I am starting now using CXF.
> I am trying to develope a webservice using CXF and Eclipse. To do so, I used
> the following guide:
>
> http://cwiki.apache.org/CXF20DOC/cxfeclipseplugininstructions.html
>
> Like the guide indicates, I made a project "WSDL First", like recommended.
> When I want to deploy the webservice I have a problem. When I right click on
> WSDL and select "Build Package", the process builds several files. 
> In these files, we can find the file "cxf-servlet.xml". My problem is with
> that file. The content of the file is the following:
>
>
> <?xml version="1.0" encoding="UTF-8"?>
> <beans xmlns="http://www.springframework.org/schema/beans"
> xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> xmlns:jaxws="http://cxf.apache.org/jaxws"
> xmlns:soap="http://cxf.apache.org/bindings/soap"
> xsi:schemaLocation="
> http://www.springframework.org/schema/beans
> http://www.springframework.org/schema/beans/spring-beans-2.0.xsd
> http://cxf.apache.org/bindings/soap
> http://cxf.apache.org/schemas/configuration/soap.xsd
> http://cxf.apache.org/jaxws http://cxf.apache.org/schemas/jaxws.xsd">
>
>
> <jaxws:endpoint
>     id="InfodemWS_xml_bare"
>     implementor="localhost._8080.infodemws.InfodemWSImpl"
>     wsdlLocation="WEB-INF/wsdl/InfodemWS.wsdl"
>     address="/InfodemWS" >
>        <jaxws:features>
>             <bean class="org.apache.cxf.feature.LoggingFeature"/>
>        </jaxws:features>
> </jaxws:endpoint>
> </beans>
>
> The file has an error: 
>
> "Multiple markers at this line.
>
> - cvc-complex-type.2.4.c: The matching wildcard is strict, but no
> declaration can be found for element 'jaxws:endpoint'
> - schema_reference.4: Failed to read schema document
> 'http://cxf.apache.org/schemas/jaxws.xsd', because 1) could not find the
> document; 2) the document coud not be read; 3) the root element of the
> document is not <xsd:schema>"
>
> I tried to access "http://cxf.apache.org/jaxws
> http://cxf.apache.org/schemas/jaxws.xsd" but the file is not found.
> I am using:
>    - Eclipse 3.3.0 with the package
> stp-all-in-one-incubation-R-R200710161054-200710161054.zip installed
>    - apache-cxf-2.0.3-incubator.zip
>
> Anyone knows how to solve the problem?
>
> thanks
>
> regards
>   

Mime
View raw message