cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jiang, Ning \(Willem\)" <Ning.Ji...@iona.com>
Subject RE: rt/javascript pom doesn't run tests
Date Thu, 01 Nov 2007 14:16:07 GMT
It is weird that adding the including */*Tests pattern does not work?
I ran "mvn clean install -Pfastinstall" from the trunk.

I tried to rename SerializationTests to SerializationTest or SerializationTestsCase. 
Run mvn can find the test.

Is there something that I am missing?

Willem.


-----Original Message-----
From: Jiang, Ning (Willem) [mailto:Ning.Jiang@iona.com]
Sent: Thu 11/1/2007 22:04
To: cxf-dev@incubator.apache.org
Subject: RE: rt/javascript pom doesn't run tests
 

Oops, I already did a quick fix for it:)

Willem.

-----Original Message-----
From: Benson Margulies [mailto:bim2007@basistech.com]
Sent: Thu 11/1/2007 21:55
To: Daniel Kulp
Cc: cxf-dev@incubator.apache.org
Subject: RE: rt/javascript pom doesn't run tests
 
I'll fix the class names.

> -----Original Message-----
> From: Daniel Kulp [mailto:dkulp@apache.org]
> Sent: Thursday, November 01, 2007 9:53 AM
> To: Benson Margulies
> Cc: cxf-dev@incubator.apache.org
> Subject: Re: rt/javascript pom doesn't run tests
> 
> On Thursday 01 November 2007, Benson Margulies wrote:
> > I cribbed the rt/javascript pom.xml from what seemed a relevant
> > example, but 'mvn' doesn't run my tests in when run from that
> > directory. Help?
> 
> Class naming issue.   Surefire is set to look for:
> **/*Test.java
> **/*TestCase.java
> 
> I think your classes are named "*Tests.java"
> 
> You could probably update the surefire config in the parent/pom.xml to
> include **/*Tests.java if you want.   I have no problem with that.
> 
> 
> --
> J. Daniel Kulp
> Principal Engineer
> IONA
> P: 781-902-8727    C: 508-380-7194
> daniel.kulp@iona.com
> http://www.dankulp.com/blog



Mime
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message