cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Yu <jeff...@iona.com>
Subject Re: JaxWS Endoints in Tomcat with no wsdl
Date Thu, 22 Nov 2007 10:38:01 GMT
Not sure if this is related to this JIRA: 
https://issues.apache.org/jira/browse/CXF-1143

I would say look at the tomcat's console to see if there are error 
stacks, that would be helpful a lot to analysis problem.

Thanks
Jeff

Sergey Beryozkin wrote:
> Hi
>
> I'm working on a test case which uses a CXFServlet which serves jaxws:endpoints with
no wsdlLocation specified. The actual service implementation is not annotated with a wsdlLocation
either.
>
> For ex, in webapps/EchoApp
>
> cxf-servlet.xml :
>
> <jaxws:endpoint id="Echo" implementor="com.cxf.EchoImpl" address="/Echo"/>
>
> web.xml :
>
> <servlet-mapping>
>         <servlet-name>CXF</servlet-name>
>         <url-pattern>/jaxws/*</url-pattern>
> </servlet-mapping>
>
> and com.cxf.EchoImpl has no annotations too.
>
> The applications is loaded just fine but requests like http://localhost:8080/EchoApp/jaxws/Echo?wsdl
>
> fail with HTTP 400 which means that endpoints have not been propely registered...?wsdl
is not even given a chance...
>
> Can somepne please give me a hint where to start looking ? I was absolutely certain I
had this test working few days ago and then it went failing again...
>
> I'm looking at 
> org.apache.cxf.service.factory.ReflectionServiceFactoryBean.createEndpoints() method
and if no wsdl is available initially then
>
> this method does not create any endpoints...
>
> Thanks, Sergey
>
>
>
>
> ----------------------------
> IONA Technologies PLC (registered in Ireland)
> Registered Number: 171387
> Registered Address: The IONA Building, Shelbourne Road, Dublin 4, Ireland
>
>   

Mime
View raw message