cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Willem Jiang <ning.ji...@iona.com>
Subject Re: Reused address problems only under maven
Date Tue, 20 Nov 2007 08:47:47 GMT
Hi Benson,

After tracing the log , I found we did not really turn off the  
"org.apache.cxf.transports.http_jetty.DontClosePort" flag in the parent 
pom.xml.

When you run the test from Eclipse the flag is not set , the jetty 
engine will be shutdown when  we call the bus.shutdown() in @After method.
Since we still set the 
"org.apache.cxf.transports.http_jetty.DontClosePort" true in the parent 
pom.xml, the jetty engine will not be shut down instead.

After I truned off the 
"org.apache.cxf.transports.http_jetty.DontClosePort" , I found there 
were dozens of systests failed. Now we still need to use 
"org.apache.cxf.transports.http_jetty.DontClosePort" flag in our parent 
pom.xml.

Willem.

Willem Jiang wrote:
> Hi Benson,
>
> I will take a look at this issue later today.
>
> Willem.
>
> Benson Margulies wrote:
>> Willem or whomever,
>>
>> If you remove the @org.junit.Ignore from JsHttpRequestTest, you will see
>> address in use binding errors from this test, which eventually result in
>> a failure. Oddly, there's no problem in eclipse, only in Maven.
>>
>> I can probably get around this by subverting JUnit via some static setup
>> that avoids reinitializing services, since for this test it would be
>> fine for all the services to come up once.
>>
>> Nonetheless, this isn't what we intend, I think, so I'm filing a JIRA.
>>
>> --benson
>>
>>
>>
>>  
>>
>>   
>

Mime
View raw message