cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Connelly <daniel.s.conne...@comcast.net>
Subject Re: Still bad generated WSDL: "The prefix ns2 is not bound."
Date Thu, 18 Oct 2007 13:37:43 GMT
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
  <meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
<br>
<big>Yes. Daniel.&nbsp;&nbsp; Thanks.&nbsp; My bad. &nbsp;&nbsp;
From now on I will always use
"-impl" so as not to confuse myself.<br>
<br>
Other problem(s) coming up now, but I will post to a different thread
when I have can isolate the test case(s).<br>
&nbsp;&nbsp; </big><br>
<br>
Daniel Kulp wrote:
<blockquote cite="mid:200710171603.00967.dkulp@apache.org" type="cite">
  <pre wrap="">On Wednesday 17 October 2007, Dan Connelly wrote:
  </pre>
  <blockquote type="cite">
    <pre wrap=""> I generate Java code from efile.wsdl&nbsp; using wsdl2java.&nbsp;&nbsp;&nbsp;
(See
attached wsdl.)&nbsp;&nbsp;&nbsp; I use this code as-is.

 I create a service Endpoint from the service class
("org.streamlinedsalestax.efile.EFileService").&nbsp;&nbsp;&nbsp; I start the
server.
    </pre>
  </blockquote>
  <pre wrap=""><!---->

That's probably the issue.   EFileService is the client side proxy 
creation service bean.   It's not the service class.

When you run wsdl2java, if you add the -impl flag, it will generate a 
sample implementation.   It would be called EFileServiceSoapImpl.   If 
you use that for the service, it should generate a better WSDL.  

Dan


  </pre>
  <blockquote type="cite">
    <pre wrap=""> Then I fetch the generated wsdl from the server and save it as
EFileService.wsdl. &nbsp;&nbsp;&nbsp; (See attached.)

 Testing will Eclipse tooling, EFileService.wsdl is invalid.

 Despite this, I attempt to run a dynamic client proxy.&nbsp;&nbsp; Error:&nbsp;&nbsp;
"The prefix ns2 is not bound."&nbsp; which is basically the same error that
Eclipse reported.

 [I think that this error has existed since Release 2.0.&nbsp;&nbsp;&nbsp; I posted
to cxf-dev on a similar problem in a 2.0 SNAPSHOT back on
06/23/2007.&nbsp;&nbsp;&nbsp; I did not follow up on it, until now.&nbsp;&nbsp;&nbsp;
Of course, I
would really like it to work now.&nbsp;&nbsp; (Please!)]

 &nbsp;&nbsp;&nbsp; &nbsp;&nbsp; -- Dan Connelly
    </pre>
  </blockquote>
  <pre wrap=""><!---->


  </pre>
</blockquote>
<br>
</body>
</html>

Mime
View raw message