cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Connelly <daniel.s.conne...@comcast.net>
Subject Re: Still bad generated WSDL: "The prefix ns2 is not bound."
Date Wed, 17 Oct 2007 19:03:55 GMT
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
  <meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
[Thunderbird lost the message I sent.&nbsp; Just sent the attachments.&nbsp;&nbsp;
Repeating the message here.]<br>
<br>
<br>
Release:&nbsp; apache-cxf-2.0.2-incubator<br>
<br>
I generate Java code from efile.wsdl&nbsp; using wsdl2java.&nbsp;&nbsp;&nbsp;
(See attached
wsdl.)&nbsp;&nbsp;&nbsp; I use this code as-is.<br>
<br>
I create a service Endpoint from the service class
("org.streamlinedsalestax.efile.EFileService").&nbsp;&nbsp;&nbsp; I start the
server.<br>
<br>
Then I fetch the generated wsdl from the server and save it as
EFileService.wsdl. &nbsp;&nbsp;&nbsp; (See attached.)<br>
<br>
Testing will Eclipse tooling, EFileService.wsdl is <u>invalid.</u><br>
<br>
Despite this, I attempt to run a dynamic client proxy.&nbsp;&nbsp; Error:&nbsp;&nbsp;
"The
prefix ns2 is not bound."&nbsp; which is basically the same error that
Eclipse reported.<br>
<br>
[I think that this error has existed since Release 2.0.&nbsp;&nbsp;&nbsp; I posted
to
cxf-dev
on a similar problem in a 2.0 SNAPSHOT back on 06/23/2007.&nbsp;&nbsp;&nbsp; I
did not
follow up on it,
until now.&nbsp;&nbsp;&nbsp; Of course, I would really like it to work now.&nbsp;&nbsp;
(Please!)]<br>
<br>
&nbsp;&nbsp;&nbsp; &nbsp;&nbsp; -- Dan Connelly<br>
<pre wrap="">
</pre>
</body>
</html>

Mime
View raw message