cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Willem Jiang <ning.ji...@iona.com>
Subject Re: Someone busted the build ?!?
Date Mon, 10 Sep 2007 00:56:17 GMT
Hi Benson,

I just ran mvn clean install on my trunk with latest code. I did not run 
into that failure.
Did you change any pom file which introduces the cyclic dependency problem?

Willem.
Benson Margulies wrote:
> [INFO] Scanning for projects...
>
> [INFO]
> ------------------------------------------------------------------------
>
> [ERROR] BUILD FAILURE
>
> [INFO]
> ------------------------------------------------------------------------
>
> [INFO] The projects in the reactor contain a cyclic reference: Edge
> between 'Vertex{label='org.apache.cxf:cxf-rt-frontend-simple'}' and
> 'Vertex{label='org.apache.cxf:cxf-rt-bindings-xml'}' introduces to cycle
> in the graph org.apache.cxf:cxf-rt-bindings-xml -->
> org.apache.cxf:cxf-rt-databinding-jaxb -->
> org.apache.cxf:cxf-tools-common -->
> org.apache.cxf:cxf-rt-databinding-aegis -->
> org.apache.cxf:cxf-rt-frontend-simple -->
> org.apache.cxf:cxf-rt-bindings-xml
>
> [INFO]
> ------------------------------------------------------------------------
>
> [INFO] For more information, run Maven with the -e switch
>
> [INFO]
> ------------------------------------------------------------------------
>
> [INFO] Total time: 3 seconds
>
> [INFO] Finished at: Sun Sep 09 20:46:03 EDT 2007
>
> [INFO] Final Memory: 8M/15M
>
> [INFO] -------------------------------------------------------
>
>
>   

Mime
View raw message