cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrea Smyth <andrea.sm...@iona.com>
Subject Re: svn commit: r542728 [1/2] - in /incubator/cxf/trunk: api/src/main/java/org/apache/cxf/tools/ api/src/main/java/org/apache/cxf/tools/validator/ api/src/main/java/org/apache/cxf/wsdl/ rt/bindings/soap/src/main/java/org/apache/cxf/binding/soap/wsdl11/ rt/...
Date Mon, 04 Jun 2007 12:07:48 GMT
James Mao wrote:

> Hi Andrea,
>
> This is not a new dependency, it's been there for a long time since we 
> refactoring tools.
> And i just tried what you tried, top '*mvn clean*' and then tools 
> '*mvn install*', and i got a successful build.
> and then go into the rt do a '*mvn install*' i got another successful 
> build.
> Tested the above on RHEL 3.0 and Windows Vista.
>
> Can you try again?
> If it still not work for you, can you please send the error message.

Hi James,

IIRC, it failed to build in tools because the newly introduced 
constructor to WsdlDefinitionBuilder (the one with a boolean argument) 
was not known.
As this was my first build including that change, this is not suprising. 
Now it works as the cxf-rt-core jar in my local repository has that 
change. I am sure I can reproduce the problem after I wipe out my local 
repository and build offline. Don't have time for that now though ..

Andrea.



Mime
View raw message