cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christopher Moesel" <>
Subject cxf-rt-transports-http's pom.xml may be bad...
Date Wed, 02 May 2007 15:53:00 GMT
I've noticed that my war files include some jars in the WEB-INF/lib that
probably shouldn't be there:
- jetty-6.12rc0.jar
- jetty-sslengine-6.1.2rc0.jar
- jetty-util-6.1.2rc0.jar
- geronimo-servlet_2.5_spec-1.1-M1.jar

I was able to track this down to the pom.xml of the
cxf-rt-transports-http module (which I need in order to use CXFServlet).
It contains the following dependencies:


I can understand why jetty would be needed in
cxf-rt-transports-http-jetty, but not in cxf-rt-transports-http.  And
geronimo-servlet_2.5_spec should probably be in the "provided" scope.

I tried removing the jetty dependencies and setting the scope of the
servlet API to provided.  I ran the tests in /rt/transports/http as well
as /systests and they all completed successfully...  So, could this POM
be fixed or is there something else going on that I'm not aware of?


View raw message