cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Glynn, Eoghan" <>
Subject RE: Conduit.send() ->
Date Sun, 01 Apr 2007 20:42:37 GMT

Sure, knock yourself out :)

As a method name, send() was always bit of a misnomer. Depends on the
transport implementation whether anything is actually sent in advance of
the output stream being flush()ed/close()ed. HTTP would stream data onto
the wire as the content is written (assuming chunking is enabled), but
AFAIK JMS doesn't write anything until the entire payload has been

Now open() sounds to me like a sort of one-off operation, only required
to be called once per Conduit, not once per message. Something like
prepare() or getContent() would be other options. But I'm not hung up on
it either way.


> -----Original Message-----
> From: Dan Diephouse [] 
> Sent: 31 March 2007 21:36
> To:
> Subject: Conduit.send() ->
> Would people be OK with renaming Conduit.send() to 
> I think it results in clearer semantics. 
> We're just opening the connection then and setting an 
> OutputStream typically. And we certainly aren't sending the 
> whole message at that point.
> Thoughts?
> - Dan
> --
> Dan Diephouse
> Envoi Solutions
> |

View raw message