cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Kulp <daniel.k...@iona.com>
Subject Re: wsdl2java build error
Date Mon, 05 Mar 2007 15:36:57 GMT
On Monday 05 March 2007 06:30, James Mao wrote:
> i guess you are using windows xp or windows 2000
> one thing you can do is
>
> subst the .m2 to a driver name (e.g s:)
> mvn install -Dmaven.repo.local=s:
>
>
> I guess it's a bug in new surefire.
> but i'm not 100% sure.
>

Actually, it's most likely a bug in our Compiler.java in tools-common.   I 
don't think it's properly escaping the spaces once the command line gets 
so long it has to switch to the @file version.   I'm not really sure.   
Not something I can debug very well considering I don't use windows.

We COULD probably consider switching to using ants javac task code.   I 
notice something in the jaxb databinding does that.

Dan



> Hope this help.
>
> James.
>
> > After an svn update I am seeing these errors in wsdl2java:
> >
> > -------------------------------------------------------
> > T E S T S
> > -------------------------------------------------------
> > Running org.apache.cxf.tools.wsdl2java.processor.WSDLToJavaMIMETest
> > Tests run: 3, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 1.873
> > sec Running
> > org.apache.cxf.tools.wsdl2java.processor.WSDLToJavaProcessorTest
> > C:\svn\main\cxf\tools\wsdl2java\target\test-classes\org\apache\cxf\too
> >ls\common\resources\org\apache\hello_world_soap_http\BadRecordLitFault.
> >java:22: package javax.xml.ws does not exist
> > import javax.xml.ws.WebFault;
> >                     ^
> > C:\svn\main\cxf\tools\wsdl2java\target\test-classes\org\apache\cxf\too
> >ls\common\resources\org\apache\hello_world_soap_http\Greeter.java:22:
> > package javax.jws.WebParam does not exist
> > import javax.jws.WebParam.Mode;
> >                           ^
> > C:\svn\main\cxf\tools\wsdl2java\target\test-classes\org\apache\cxf\too
> >ls\common\resources\org\apache\hello_world_soap_http\Greeter.java:23:
> > package javax.jws does not exist
> > import javax.jws.WebParam;
> > ....
> >
> > Wiping out my local repository did not help either. Is anyone else
> > seeing this?
> >
> > Andrea.

-- 
J. Daniel Kulp
Principal Engineer
IONA
P: 781-902-8727    C: 508-380-7194
daniel.kulp@iona.com
http://www.dankulp.com/blog

Mime
View raw message