cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Jencks <david_jen...@yahoo.com>
Subject Re: maven question
Date Sat, 30 Dec 2006 03:43:01 GMT
This is kind of a dumb suggestion but you might need to build the  
project before you run -Psetup.eclipse so all the artifacts are  
available.

david jencks

On Dec 29, 2006, at 10:22 PM, Steve Olson wrote:

> I've done a CXF checkout today for the first time, and am trying to  
> do the maven eclipse setup (-Psetup.eclipse). Maven cranks for a  
> while then fails with this:
>
> [INFO]  
> ---------------------------------------------------------------------- 
> --
> [ERROR] BUILD ERROR
> [INFO]  
> ---------------------------------------------------------------------- 
> --
> [INFO] Failed to resolve artifact.
>
> Missing:
> ----------
> 1) org.apache.cxf:cxf-buildtools:jar:2.0-incubator-RC-SNAPSHOT
>
>   Try downloading the file manually from the project website.
>
>   Then, install it using the command:
>       mvn install:install-file -DgroupId=org.apache.cxf - 
> DartifactId=cxf-buildtools
>           -Dversion=2.0-incubator-RC-SNAPSHOT -Dpackaging=jar - 
> Dfile=/path/to/file
>
>   Path to dependency:
>         1) org.apache.maven.plugins:maven-antrun-plugin:maven- 
> plugin:1.1
>         2) org.apache.cxf:cxf-buildtools:jar:2.0-incubator-RC-SNAPSHOT
>
> ----------
> 1 required artifact is missing.
>
> for artifact:
>   org.apache.maven.plugins:maven-antrun-plugin:maven-plugin:1.1
>
> from the specified remote repositories:
>   snapshots (http://snapshots.maven.codehaus.org/maven2),
>   central (http://repo1.maven.org/maven2)
>
> What do I need to do to correct this?  Thanks in advance for any  
> help - this is my first look at CXF from the maven side and I'm  
> just beginning to learn the setup.  I'm trying to get a build  
> environment working so I can contribute a patch for CXF-340.


Mime
View raw message