cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Willem Jiang <ning.ji...@iona.com>
Subject Re: We should upgrade to activemq 4.1.0-incubator
Date Tue, 19 Dec 2006 05:59:47 GMT
Hi Adi,

I just did a quick google search.
I gussed your mentioned the issues of ActiveMQ 4.0.x brokers talking to
4.1 client was caused by wireformat negociation.
http://www.nabble.com/Release-schedule-tf2124265.html#a6647640

This issue has been fixed in 4.0.2 and 4.1.0.
https://issues.apache.org/activemq/browse/AMQ-913

I just run a test by starting up 4.0.2's broker to talk with the 4.1.0's
client. The test was succeeded.

Cheers,
Willem.

Sakala, Adinarayana wrote:

>Thanks Willem. This is great news.
>
>Do you know answer to my other question i.e if ActiveMQ is wirelevel compatible between
4.0.x and 4.1?
>Say 4.1 client talking to a 4.0.2 broker.
>I know back in October, they had some issues with ActiveMQ 4.0.x brokers talking to 4.1.
Not sure if they are resolved for the release or not?
>
>Thanks,
>adi
>
>  
>
>>-----Original Message-----
>>From: Willem Jiang [mailto:ning.jiang@iona.com]
>>Sent: Monday, December 18, 2006 9:34 PM
>>To: cxf-dev@incubator.apache.org
>>Subject: Re: We should upgrade to activemq 4.1.0-incubator
>>
>>Hi Adi,
>>
>>Because AcitveMQ fully supports JMS 1.1 API. CXF JMS transport is based
>>on JMS API, the only thing related to ActiveMQ is it's ActiveMQ
>>MessageBroker startup code.
>>I had checked the ActiveMQ 4.0.2 and 4.1.0's release note. There is no
>>major change on the MessageBroker side.
>>
>>Basicly I just updated the pom.xml to let CXF JMS transport module
>>project depend on the ActiveMQ 4.1.0, and there is no other change need
>>to make on CXF side.
>>The unit tests and system tests were passed with my yesterday's commit.
>>http://svn.apache.org/viewvc?view=rev&rev=488102
>>
>>Cheers,
>>
>>Willem.
>>
>>Sakala, Adinarayana wrote:
>>
>>    
>>
>>>Hi Willem
>>>
>>>Is ActiveMQ 4.1 backward compatible with ActiveMQ 4.0.2 version that we
>>>      
>>>
>>currently depend upon?
>>    
>>
>>>Can ActiveMQ 4.1 interop with 4.0.x releases?
>>>
>>>What does it mean to upgrade to 4.1 release? Can you briefly describe
>>>      
>>>
>>what type of config/API/transport changes will be required for CXF?
>>    
>>
>>>Thanks,
>>>Adi Sakala
>>>
>>>
>>>
>>>      
>>>


Mime
View raw message