cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sakala, Adinarayana" <ASAK...@iona.com>
Subject RE: We should upgrade to activemq 4.1.0-incubator
Date Tue, 19 Dec 2006 04:19:42 GMT
Thanks Willem. This is great news.

Do you know answer to my other question i.e if ActiveMQ is wirelevel compatible between 4.0.x
and 4.1?
Say 4.1 client talking to a 4.0.2 broker.
I know back in October, they had some issues with ActiveMQ 4.0.x brokers talking to 4.1. Not
sure if they are resolved for the release or not?

Thanks,
adi

> -----Original Message-----
> From: Willem Jiang [mailto:ning.jiang@iona.com]
> Sent: Monday, December 18, 2006 9:34 PM
> To: cxf-dev@incubator.apache.org
> Subject: Re: We should upgrade to activemq 4.1.0-incubator
> 
> Hi Adi,
> 
> Because AcitveMQ fully supports JMS 1.1 API. CXF JMS transport is based
> on JMS API, the only thing related to ActiveMQ is it's ActiveMQ
> MessageBroker startup code.
> I had checked the ActiveMQ 4.0.2 and 4.1.0's release note. There is no
> major change on the MessageBroker side.
> 
> Basicly I just updated the pom.xml to let CXF JMS transport module
> project depend on the ActiveMQ 4.1.0, and there is no other change need
> to make on CXF side.
> The unit tests and system tests were passed with my yesterday's commit.
> http://svn.apache.org/viewvc?view=rev&rev=488102
> 
> Cheers,
> 
> Willem.
> 
> Sakala, Adinarayana wrote:
> 
> >Hi Willem
> >
> >Is ActiveMQ 4.1 backward compatible with ActiveMQ 4.0.2 version that we
> currently depend upon?
> >Can ActiveMQ 4.1 interop with 4.0.x releases?
> >
> >What does it mean to upgrade to 4.1 release? Can you briefly describe
> what type of config/API/transport changes will be required for CXF?
> >
> >Thanks,
> >Adi Sakala
> >
> >
> >
> >>-----Original Message-----
> >>From: Jiang, Ning (Willem) [mailto:Ning.Jiang@iona.com]
> >>Sent: Saturday, December 16, 2006 9:43 PM
> >>To: cxf-dev@incubator.apache.org
> >>Subject: 答复: We should upgrade to activemq 4.1.0-incubator
> >>
> >>Hi Dan,
> >>
> >>I will take care of it.
> >>
> >>Thanks,
> >>
> >>Willem.
> >>
> >>
> >>
> >>-----Original Message-----
> >>From: Daniel Kulp [mailto:daniel.kulp@iona.com]
> >>Sent: 12/16/2006 (星期六) 1:35
> >>To: cxf-dev@incubator.apache.org
> >>Subject: We should upgrade to activemq 4.1.0-incubator
> >>
> >>
> >>I just realized that the ActiveMQ team released 4.1.0-incubator and it's
> >>available in the "normal" incubator maven repository:
> >>
> >>http://people.apache.org/repo/m2-incubating-
> >>repository/org/apache/activemq/
> >>
> >>We should update our builds to use that instead of the RC6 thing found
> in
> >>whomever's home directory.
> >>
> >>Thoughts?
> >>--
> >>J. Daniel Kulp
> >>Principal Engineer
> >>IONA
> >>P: 781-902-8727    C: 508-380-7194
> >>daniel.kulp@iona.com
> >>
> >>
> >
> >
> >
> >


Mime
View raw message