cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Diephouse <...@envoisolutions.com>
Subject Re: Distribution error
Date Sat, 14 Oct 2006 10:50:16 GMT
I think it might have been a one time problem as I renamed the files so 
they used a capital W a while back. Maybe your class files never got 
deleted and since windows can't differ between upper/lower case it 
caused issues.

- Dan

Shaw, Richard A wrote:

>When I run cmd - it says that I'm on Windows XP version 5.1.2600
>Maven is version 2.0.4
>JDK is 1.5.0_04
>
>I deleted the two offending .class files and rebuilt and the files were created correctly
this time.
>
>I have to admit I have no idea where to start looking for this, I have always assumed
that the name of the .class file is the name of the .java file with the extension renamed
(or it is the name of the class in the .java file with .class added to the end). Either of
these would results in the correct filename, so I don't know where the wrong one has come
from.  
>
>
>Richard Shaw
>
>¤º°`°º¤ø,¸¸,ø¤º°`°º¤ø¤º°`°º¤ø,¸¸,ø¤º°`°º¤ø¤º°`°º¤ø,¸¸,ø¤
>
>Richard Shaw  
>Technical Design Authority - Information Solutions Consultancy  
>Intelligent Transport Systems 
>
>Atkins Highways and Transportation 
>Woodcote Grove, Ashley Road, Epsom, Surrey, KT18 5BW
>
>Tel: +44 (0) 1372 756407 
>Fax: +44 (0) 1372 740055
>Mob: 07740 817586 
>E-mail: richard.shaw@atkinsglobal.com
>
>www.atkinsglobal.com/its
>
>-----Original Message-----
>From: Jiang, Ning (Willem) [mailto:Ning.Jiang@iona.com] 
>Sent: 13 October 2006 16:00
>To: cxf-dev@incubator.apache.org
>Subject: RE: Distribution error
>
>Hi Richard,
>
>I had build the kit with latest code in Windows XP sp2 with just cmd no cgwin, and Linux
RedHat ES4 , it is OK for me to run the sample.  
>Can you give us your OS , JDK, and the shell vesion?
>Please also make sure your maven install directory (using the trunk\maven) :)
>
>Thanks,
>Willem.
>
>
>-----Original Message-----
>From: Shaw, Richard A [mailto:richard.shaw@atkinsglobal.com]
>Sent: 10/13/2006  22:28
>To: cxf-dev@incubator.apache.org
>Subject: Distribution error
> 
>I've just build the latest distribution from SVN and it doesn't work. I've discovered
that it is because -
>
>When JaxWsImplementorInfo.java is built it generates JaxwsImplementorInfo.class (with
a small w).
>
>When I try to run anything I get class not found for JaxWsImplementorInfo. I renamed my
.class file in the jar file and it works. 
>
>I also noticed that JaxwsEndpointImpl.class also had a small w - so I changed that too.
>
>I'm not familiar enough with maven to try and find out what caused this.
>
>(I'm using Windows if that makes any difference).
>
>Richard Shaw
>
>¤o°`°o¤?,??,?¤o°`°o¤?¤o°`°o¤?,??,?¤o°`°o¤?¤o°`°o¤?,??,?¤
>
>Richard Shaw
>Technical Design Authority - Information Solutions Consultancy Intelligent Transport Systems

>
>Atkins Highways and Transportation
>Woodcote Grove, Ashley Road, Epsom, Surrey, KT18 5BW
>
>Tel: +44 (0) 1372 756407
>Fax: +44 (0) 1372 740055
>Mob: 07740 817586
>E-mail: richard.shaw@atkinsglobal.com
>
>www.atkinsglobal.com/its
>
>
>
>This email and any attached files are confidential and copyright protected. If you are
not the addressee, any dissemination of this communication is strictly prohibited. Unless
otherwise expressly agreed in writing, nothing stated in this communication shall be legally
binding.
>
>
>
>This message has been scanned for viruses by MailControl - (see http://bluepages.wsatkins.co.uk/?4318150)
>  
>


-- 
Dan Diephouse
(616) 971-2053
Envoi Solutions LLC
http://netzooid.com


Mime
View raw message