cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Kulp <daniel.k...@iona.com>
Subject Re: jsr173-api-1.0.jar and stax_api-1.0.jar
Date Thu, 19 Oct 2006 14:12:37 GMT
On Wednesday October 18 2006 9:15 pm, Dan Diephouse wrote:
> Bozhong Lin wrote:
> > Does anyone has any idea why we have both jsr173-api-1.0.jar and
> > stax_api-1.0.jar? They seem to contain the same set of binary
> > classes, which all belong to Stax api classes.
> Probably errors in dependency's poms. Some include stax-api, some
> include jsr173. I suppose the later is more correct, but the former has
> been around long (then maven people didn't add jsr173 until later).
> Also, the stax API's current version is 1.0.1 so we might want to think
> about using that, however probably not critical ifit involves a lot of
> POM changes.

Just FYI: changing version numbers should NEVER involve a "lot of POM 
changes."    There is a dependencyManagement section of the top level pom 
that should define all the versions of the "stuff" that is depended on by 
all the other artifacts.    In ALL the other poms, the <version> tag 
should be left out of all dependencies so the version in the top level 
pom is picked up.    Thus, it's "easy" to update the entire tree.

Enjoy!
-- 
J. Daniel Kulp
Principal Engineer
IONA
P: 781-902-8727    C: 508-380-7194   F:781-902-8001
daniel.kulp@iona.com

Mime
View raw message