cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Jones <peter.jo...@iona.com>
Subject Re: Problem with SOAPDocLitClientTypeTest on windows?
Date Thu, 05 Oct 2006 19:40:21 GMT

Hi Dan,

On Thu, Oct 05, 2006 at 02:25:46PM -0400, Dan Diephouse wrote:
> My WSDL actually has this import in it:
> 
> <xsd:import namespace="http://apache.org/type_test/types1" 
> schemaLocation="C:\cygwin\home\Dan\cxf\trunk\testutils/target/generated/src/main/resources/wsdl/type_test/type_test_1.xsd"/>
> 
> On IRC Dan Kulp said his was:
> <xsd:import namespace="http://apache.org/type_test/types1" 
> schemaLocation="./type_test_1.xsd"/>
> 
> With that change it works. Hrmph. It appears to be a generated wsdl. I'm 
> not sure what I need to do to fix the generation though...


Hmm... Just built on windows, and the xslt generated wsdl file has this:

    <xsd:import namespace="http://apache.org/type_test/types1"
                schemaLocation="./type_test_1.xsd"/>

The pom.xml in testutils should pass in an inc_xsd_path parameter of "." when
generating that wsdl.  Not sure whats different in your build. 

I guess that's not very helpful... sorry. :(

Cheers,
Peter

> - Dan
> 
> Dan Diephouse wrote:
> > Anyone else having issues with the SOAPDocLitClientTypeTest  on 
> > windows? I get this message:
> >
> > Caused by: org.apache.ws.commons.schema.XmlSchemaException: 
> > C:\cygwin\home\Dan\cxf\trunk\testutils\target\generated\src\main\resources\wsdl\type_test\type_test_doclit.wsdl\C:\cygwin\home\Dan\cxf\trunk\testutils\target\generated\src\main\resources\wsdl\type_test\type_test_1.xsd

> > (The filename, directory name, or volume label syntax is incorrect)
> >    at 
> > org.apache.ws.commons.schema.XmlSchemaCollection.read(XmlSchemaCollection.java:221)

> >
> >    at 
> > org.apache.ws.commons.schema.SchemaBuilder.resolveXmlSchema(SchemaBuilder.java:1911)

> >
> >    ... 17 more
> >
> > Granted, I'm ultimately liable for the blame because I think I wrote 
> > the resolution code in XmlSchema, but I'm wondering if this test ever 
> > worked on windows or its something to do with my changes. Can anyone 
> > let me know if it passes for them?
> >
> > - Dan
> >
> 
> 
> -- 
> Dan Diephouse
> Envoi Solutions
> http://envoisolutions.com
> http://netzooid.com/blog

-- 
Peter Jones
IONA Technologies Inc.
E-Mail: mailto:peter.jones@iona.com
Tel: (w) 709-738-3725 x22 | Fax: 709-738-3745
84-86 Elizabeth Ave. St. John's, NL A1A 1W7 Canada

Mime
View raw message