cxf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Liu, Jervis" <j...@iona.com>
Subject RE: Invalid wsdl generated in testutil
Date Thu, 14 Sep 2006 02:59:19 GMT
Hi,  this is a xslt script problem. I will take a look tomorrow. 

Cheers,
Jervis

> -----Original Message-----
> From: Ma, Erqiang (Jim) 
> Sent: Monday, September 11, 2006 5:55 PM
> To: cxf-dev@incubator.apache.org
> Subject: RE: Invalid wsdl generated in testutil
> 
> 
> Correct my mistake . 
> 
> These wsdls are generated by Maven XSLT plugin. 
> 
> 
> Regards
> 
> Jim
> 
> > -----Original Message-----
> > From: Jim Ma [mailto:jim.ma@iona.com]
> > Sent: Monday, September 11, 2006 5:19 PM
> > To: cxf-dev@incubator.apache.org
> > Subject: Invalid wsdl generated in testutil
> > 
> > 
> > Hi All , 
> > 
> > I found there are 3 invalid wsdls generated (by XSD code gen 
> > plugin)  in testutil : 
> > 
> > [1]  type_test_rpclit.wsdl   : Message part  "x " in message 
> > "testNillableString" attempt to use parameter as complex type, 
> > but parameter defined as an element.
> > 
> > [2] type_test_xml.wsdl  : operation "testNillableString" are not 
> > defined in portType
> > 
> > [3] type_test_rpclit_soap.wsdl :  Message part  "x " in message 
> > "testNillableString" attempt to use parameter as complex type, 
> > but parameter defined as an element
> > 
> > Is this the XSD2java plugin issue  or script issue ?
> > 
> > 
> > Thanks 
> > 
> > Jim
> > 
> > 
> > 
> > 
> > 
> > 
> > 
> > 
> 
> 
Mime
View raw message