cxf-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From cohei...@apache.org
Subject cxf git commit: Log a warning when WSS4J not found.
Date Fri, 15 Jan 2016 16:43:03 GMT
Repository: cxf
Updated Branches:
  refs/heads/3.1.x-fixes 29638f6c2 -> cf3584f33


Log a warning when WSS4J not found.


Project: http://git-wip-us.apache.org/repos/asf/cxf/repo
Commit: http://git-wip-us.apache.org/repos/asf/cxf/commit/cf3584f3
Tree: http://git-wip-us.apache.org/repos/asf/cxf/tree/cf3584f3
Diff: http://git-wip-us.apache.org/repos/asf/cxf/diff/cf3584f3

Branch: refs/heads/3.1.x-fixes
Commit: cf3584f3357b850781f8339c278f5a49598f0286
Parents: 29638f6
Author: Colm O hEigeartaigh <coheigea@apache.org>
Authored: Fri Jan 15 16:37:21 2016 +0000
Committer: Colm O hEigeartaigh <coheigea@apache.org>
Committed: Fri Jan 15 16:42:58 2016 +0000

----------------------------------------------------------------------
 .../apache/cxf/ws/security/policy/WSSecurityPolicyLoader.java   | 5 +----
 1 file changed, 1 insertion(+), 4 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/cxf/blob/cf3584f3/rt/ws/security/src/main/java/org/apache/cxf/ws/security/policy/WSSecurityPolicyLoader.java
----------------------------------------------------------------------
diff --git a/rt/ws/security/src/main/java/org/apache/cxf/ws/security/policy/WSSecurityPolicyLoader.java
b/rt/ws/security/src/main/java/org/apache/cxf/ws/security/policy/WSSecurityPolicyLoader.java
index 5f2c1e9..f149056 100644
--- a/rt/ws/security/src/main/java/org/apache/cxf/ws/security/policy/WSSecurityPolicyLoader.java
+++ b/rt/ws/security/src/main/java/org/apache/cxf/ws/security/policy/WSSecurityPolicyLoader.java
@@ -107,12 +107,9 @@ public final class WSSecurityPolicyLoader implements PolicyInterceptorProviderLo
         try {
             registerProviders();
         } catch (Throwable t) {
-            //probably wss4j isn't found or something. We'll ignore this
-            //as the policy framework will then not find the providers
-            //and error out at that point.  If nothing uses ws-securitypolicy
-            //no warnings/errors will display
             String error = "Could not load or register WS-SecurityPolicy related classes.
"
                 + "Please check that (the correct version of) Apache WSS4J is on the classpath";
+            LOG.log(Level.WARNING, error + ": " + t.getMessage());
             LOG.log(Level.FINE, error, t);
         }
     }


Mime
View raw message