curator-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jordan Zimmerman <jor...@jordanzimmerman.com>
Subject Re: [ANN] Exhibitor 1.5.3
Date Mon, 09 Feb 2015 03:06:26 GMT
Do you want to build a WAR file or the standard build? The standard build is Gradle. clone
the project and run ./gradlew. The POM files are for making WAR files. I tend to forget to
update the versions in them. Sorry about that.

-JZ



On February 8, 2015 at 7:16:19 PM, Check Peck (comptechgeeky@gmail.com) wrote:

Hi Jordan,

How can we build 1.5.3 exhibitor locally? Earlier, I was following this link to do that -
https://github.com/Netflix/exhibitor/wiki/Building-Exhibitor

But in that link, I can still see in the pom file, that version is "1.5.1". Do I just need
to change that to "1.5.3"? And build it same way as mentioned in the above link?


On Mon, Feb 2, 2015 at 4:52 PM, Jordan Zimmerman <jordan@jordanzimmerman.com> wrote:
Exhibitor 1.5.3 - February 2, 2015
===========================

* Pull 189: Need to pad converted hex bytes. Thanks to user jamesmulcahy

* Issue 201: Need to set peerType=observer for Observers

* Issue 191: S3ClientImpl does not pass internet proxy server configuration to AmazonS3Client. 
Thank you to user boldfield.

* Pull 216: Change restart behavior. An addition of an observer no longer causes all instances
to restart.

* Pull 221: Updated Gradle build

* Updated all dependencies, etc. to reasonbly recent versions.





Mime
View raw message