curator-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CURATOR-432) OSGI bundles should not import org.apache.curator
Date Wed, 10 Jan 2018 11:22:00 GMT

    [ https://issues.apache.org/jira/browse/CURATOR-432?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16320096#comment-16320096
] 

ASF GitHub Bot commented on CURATOR-432:
----------------------------------------

Github user iocanel commented on a diff in the pull request:

    https://github.com/apache/curator/pull/237#discussion_r160649759
  
    --- Diff: curator-framework/pom.xml ---
    @@ -100,6 +100,27 @@
                         </execution>
                     </executions>
                 </plugin>
    +            <plugin>
    +                <groupId>org.apache.felix</groupId>
    +                <artifactId>maven-bundle-plugin</artifactId>
    +                <version>3.3.0</version>
    +                <extensions>true</extensions>
    +                <configuration>
    +                    <instructions>
    +                        <Import-Package>!org.apache.curator,*</Import-Package>
    --- End diff --
    
    There is no need to define the plugin again. The plugin is defined once in the parent
pom and inherited from the rest of the modules.
    
    To customize a modules configuration please set properties:
    - `osgi.import.package`
    - `osgi.export.package`


> OSGI bundles should not import org.apache.curator
> -------------------------------------------------
>
>                 Key: CURATOR-432
>                 URL: https://issues.apache.org/jira/browse/CURATOR-432
>             Project: Apache Curator
>          Issue Type: Bug
>            Reporter: Christopher Johnson
>            Assignee: Jordan Zimmerman
>            Priority: Minor
>
> Curator bundles will not deploy to an OSGI container like Karaf with an import requirement
on a non-existent package.  The problem is highlighted in the excerpt from the MANIFEST.MF
below
> {code:java}
> Import-Package: com.google.common.base;version="[20.0,21)",com.google.
>  common.collect;version="[20.0,21)",com.google.common.util.concurrent;
>  version="[20.0,21)",*org.apache.curator;version="[4.0,5)"*,org.apache.c
>  urator.framework;version="[4.0,5)",org.apache.curator.framework.api;v
>  ersion="[4.0,5)",org.apache.curator.framework.api.transaction;version
>  ="[4.0,5)",org.apache.curator.framework.imps;version="[4.0,5)",org.ap
>  ache.curator.framework.listen;version="[4.0,5)",org.apache.curator.fr
>  amework.state;version="[4.0,5)",org.apache.curator.retry;version="[4.
>  0,5)",org.apache.curator.utils;version="[4.0,5)",org.apache.zookeeper
>  ;version="[3.5,4)",org.apache.zookeeper.data;version="[3.5,4)",org.sl
>  f4j;version="[1.7,2)"
> {code}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message