curator-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jordan Zimmerman (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CURATOR-446) Compile error with tests using 4.0.0 and ZK 3.4.11 - need to update docs on how to use old test lib
Date Tue, 19 Dec 2017 02:19:00 GMT

     [ https://issues.apache.org/jira/browse/CURATOR-446?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jordan Zimmerman updated CURATOR-446:
-------------------------------------
    Fix Version/s: 4.0.1

> Compile error with tests using 4.0.0 and ZK 3.4.11 - need to update docs on how to use
old test lib
> ---------------------------------------------------------------------------------------------------
>
>                 Key: CURATOR-446
>                 URL: https://issues.apache.org/jira/browse/CURATOR-446
>             Project: Apache Curator
>          Issue Type: Task
>          Components: Documentation, Tests
>    Affects Versions: 4.0.0
>         Environment: gradle:
> compile('org.apache.zookeeper:zookeeper:3.4.11')
> testCompile ('org.apache.curator:curator-test:4.0.0') {
>     exclude group: 'org.apache.zookeeper', module: 'zookeeper'
> }
>            Reporter: Greg Moulliet
>            Priority: Minor
>             Fix For: 4.0.1
>
>
> Attempting to start a test ZK gives the following error:
> Exception in thread "Thread-0" java.lang.NoSuchFieldError: configFileStr
> 	at org.apache.curator.test.QuorumConfigBuilder$1.<init>(QuorumConfigBuilder.java:142)
> 	at org.apache.curator.test.QuorumConfigBuilder.buildConfig(QuorumConfigBuilder.java:137)
> 	at org.apache.curator.test.TestingZooKeeperServer$1.run(TestingZooKeeperServer.java:157)
> 	at java.lang.Thread.run(Thread.java:745)
> Reverting back to 2.12.0 resolves the issue for me.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message