curator-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vladimir Dergachev (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CURATOR-403) Curator framework incompatible with guava 21
Date Thu, 27 Apr 2017 10:59:04 GMT

     [ https://issues.apache.org/jira/browse/CURATOR-403?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Vladimir Dergachev updated CURATOR-403:
---------------------------------------
    Description: 
Guava version 21 incompatible with curator framework. Now it uses version 16.0.1 of guava,
and compatible up to version 20 inclusive. To reproduce a problem just put 21 version in dependencies
management and you will get message like this in runtime.
{code}
Caused by: java.lang.NoSuchMethodError: com.google.common.util.concurrent.MoreExecutors.sameThreadExecutor()Lcom/google/common/util/concurrent/ListeningExecutorService;
	at org.apache.curator.framework.listen.ListenerContainer.addListener(ListenerContainer.java:41)
{code}

  was:
Guava version 21 incompatible with curator framework. Now it uses version 16.0.1 of guava,
and compatible up to version 20 inclusive. To reproduce a problem just put 21 version in dependencies
management. You will got message like this 
{code}
Caused by: java.lang.NoSuchMethodError: com.google.common.util.concurrent.MoreExecutors.sameThreadExecutor()Lcom/google/common/util/concurrent/ListeningExecutorService;
	at org.apache.curator.framework.listen.ListenerContainer.addListener(ListenerContainer.java:41)
{code}


> Curator framework incompatible with guava 21
> --------------------------------------------
>
>                 Key: CURATOR-403
>                 URL: https://issues.apache.org/jira/browse/CURATOR-403
>             Project: Apache Curator
>          Issue Type: Bug
>          Components: Framework
>    Affects Versions: 3.3.0, 2.12.0
>            Reporter: Vladimir Dergachev
>
> Guava version 21 incompatible with curator framework. Now it uses version 16.0.1 of guava,
and compatible up to version 20 inclusive. To reproduce a problem just put 21 version in dependencies
management and you will get message like this in runtime.
> {code}
> Caused by: java.lang.NoSuchMethodError: com.google.common.util.concurrent.MoreExecutors.sameThreadExecutor()Lcom/google/common/util/concurrent/ListeningExecutorService;
> 	at org.apache.curator.framework.listen.ListenerContainer.addListener(ListenerContainer.java:41)
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message