curator-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jordan Zimmerman <jor...@jordanzimmerman.com>
Subject Re: Unit tests failing
Date Thu, 14 Jan 2016 23:51:19 GMT
FYI - I’m working on some thread interrupt issues for CURATOR-208. I just ran a full “mvn
clean test” successfully. I’ll push my changes soon.

-JZ

> On Jan 14, 2016, at 6:49 PM, Cameron McKenzie <mckenzie.cam@gmail.com> wrote:
> 
> I'll have a look at whether it was working pre CURATOR-278. I'm fairly sure
> it's related to that fix, and I think that the test case is ok.
> 
> On Fri, Jan 15, 2016 at 1:20 AM, Jordan Zimmerman <
> jordan@jordanzimmerman.com> wrote:
> 
>> OK - I’ll have a look. However, someone submitted that test and I don’t
>> know the code at all. So, it may take me some time.
>> 
>> -JZ
>> 
>>> On Jan 13, 2016, at 11:19 PM, Cameron McKenzie <mckenzie.cam@gmail.com>
>> wrote:
>>> 
>>> Jordan,
>>> Can you have a look at TestLeaderSelectorEdges:
>>> createProtectedNodeInBackgroundTest? I've had a bit of a look into it,
>> and
>>> I'm pretty sure that it's something to do with the changes made for
>>> CURATOR-209. It's failing about 90% of the time for me. Seems like under
>>> some conditions a failed create of a sequential ephemeral node does not
>> get
>>> cleaned up correctly, but I'm struggling to work out what exactly.
>>> cheers
>>> 
>>> On Wed, Jan 13, 2016 at 1:22 PM, Cameron McKenzie <
>> mckenzie.cam@gmail.com>
>>> wrote:
>>> 
>>>> Thanks, just checked on builds.apache.org and the same tests seem to be
>>>> failing there also. I'll try and look into it when I get a minute.
>>>> cheers
>>>> 
>>>> On Wed, Jan 13, 2016 at 8:39 AM, Jordan Zimmerman <
>>>> jordan@jordanzimmerman.com> wrote:
>>>> 
>>>>> Sorry - I haven’t. I’ll try soon. You can also use Apache’s Jenkins.
>>>>> 
>>>>>> On Jan 12, 2016, at 4:09 PM, Cameron McKenzie <mckenzie.cam@gmail.com
>>> 
>>>>> wrote:
>>>>>> 
>>>>>> Did you get time to run these unit tests in your environment Jordan?
I
>>>>> want
>>>>>> to make sure that the unit tests are passing before I merge
>> CURATOR-278.
>>>>>> 
>>>>>> The tests failing are not related to this JIRA, but still, I don't
>> want
>>>>> to
>>>>>> merge with tests failing.
>>>>>> cheers
>>>>>> 
>>>>>> On Tue, Jan 12, 2016 at 1:44 PM, Jordan Zimmerman <
>>>>>> jordan@jordanzimmerman.com> wrote:
>>>>>> 
>>>>>>> I haven’t tested in a while. I’ll have a look.
>>>>>>> 
>>>>>>>> On Jan 11, 2016, at 9:43 PM, Cameron McKenzie <
>> mckenzie.cam@gmail.com
>>>>>> 
>>>>>>> wrote:
>>>>>>>> 
>>>>>>>> Guys,
>>>>>>>> Is anyone else having issues with the
>>>>>>>> TestResetConnectionWithBackgroundFailure:testConnectionStateListener
>>>>>>> test?
>>>>>>>> 
>>>>>>>> It is consistently failing for me because the last LOST event
is not
>>>>>>> being
>>>>>>>> generated. Any ideas?
>>>>>>>> 
>>>>>>>> I'm also seeing consistent failure of
>>>>>>>> 
>>>>>>>> TestLeaderSelectorEdges:createProtectedNodeInBackgroundTest
>>>>>>>> 
>>>>>>>> java.lang.AssertionError: Still 1 znodes under /mylock lock
expected
>>>>> [0]
>>>>>>>> but found [1]
>>>>>>>> 
>>>>>>>> cheers
>>>>>>> 
>>>>>>> 
>>>>> 
>>>>> 
>>>> 
>> 
>> 


Mime
View raw message