curator-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jordan Zimmerman (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CURATOR-96) Upgrade to ZooKeeper 3.4.6 and other Dependency Updates
Date Fri, 23 May 2014 15:13:02 GMT

    [ https://issues.apache.org/jira/browse/CURATOR-96?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14007228#comment-14007228
] 

Jordan Zimmerman commented on CURATOR-96:
-----------------------------------------

All Curator deps updated and normalized. Now, all dependency versions are set as properties.
Also, got rid of some unnecessary deps in the POM that were causing problems "out there".

        <maven-project-info-reports-plugin-version>2.7</maven-project-info-reports-plugin-version>
        <maven-javadoc-plugin-version>2.9.1</maven-javadoc-plugin-version>
        <maven-dependency-plugin-version>2.8</maven-dependency-plugin-version>
        <maven-install-plugin-version>2.5.1</maven-install-plugin-version>
        <maven-compiler-plugin-version>3.1</maven-compiler-plugin-version>
        <maven-bundle-plugin-version>2.3.7</maven-bundle-plugin-version>
        <maven-surefire-plugin-version>2.17</maven-surefire-plugin-version>
        <maven-javadoc-plugin-version>2.9.1</maven-javadoc-plugin-version>
        <maven-site-plugin-version>3.3</maven-site-plugin-version>
        <doxia-module-confluence-version>1.5</doxia-module-confluence-version>
        <maven-scm-publish-plugin-version>1.0</maven-scm-publish-plugin-version>
        <maven-license-plugin-version>1.9.0</maven-license-plugin-version>
        <maven-release-plugin-version>2.5</maven-release-plugin-version>
        <apache-rat-plugin-version>0.10</apache-rat-plugin-version>
        <javassist-version>3.18.1-GA</javassist-version>
        <commons-math-version>2.2</commons-math-version>
        <jackson-mapper-asl-version>1.9.13</jackson-mapper-asl-version>
        <jersey-version>1.18.1</jersey-version>
        <jsr311-api-version>1.1.1</jsr311-api-version>
        <jetty-version>6.1.26</jetty-version>
        <scannotation-version>1.0.2</scannotation-version>
        <resteasy-jaxrs-version>2.3.0.GA</resteasy-jaxrs-version>
        <zookeeper-version>3.4.6</zookeeper-version>
        <guava-version>16.0.1</guava-version>
        <testng-version>6.8.8</testng-version>


> Upgrade to ZooKeeper 3.4.6 and other Dependency Updates
> -------------------------------------------------------
>
>                 Key: CURATOR-96
>                 URL: https://issues.apache.org/jira/browse/CURATOR-96
>             Project: Apache Curator
>          Issue Type: Task
>          Components: Client, Framework, Recipes
>    Affects Versions: 2.4.1
>            Reporter: Jordan Zimmerman
>            Assignee: Jordan Zimmerman
>             Fix For: 2.5.0
>
>
> ZooKeeper 3.4.6 has been released. Upgrade and test, etc. Also, update various other
dependency versions.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message