ctakes-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Xi Liang <xi.liang.d...@gmail.com>
Subject cannot load negation annotator
Date Mon, 03 Oct 2016 00:43:04 GMT
Hi guys,

I am new to cTake and would like to ask a maybe naive questions. I am using
the current newest version 3.2

I am trying to identify the disease of a documentation and exclude the
negations. It seems that the
desc/ctake_clinical_pipeline/desc/analysis_enginer/AggregatedPlaintestUMLSProcessor.xnl
does not annotate negation. Therefore I tried to use two other method and
have difficulty using both of them

First method:
-----------------------------
I load NegationAnnotator.xml from
desc/ctake_clinical_pipeline/desc/analysis_enginer/
I then run this annotator by click Run -> NegationAnnotator. However it
gives me error of:

org.apach.unima.analysis_engine.AnalysisEngineProcessException: JCas type
"org/apache.ctake.typesystem.type.textspan.Sentist" used in Java code, but
was not declared in the XML type descriptor.

Any idea on the error. Am I running the right command?

Second method:
------------------------------
I load NegationAnnotator.xml from desc/ctake_ne_contexts/desc
I then run Run-> NegationAnnotator.
It gives me the same error.

I also tried some other annotators. Quite many of them gave me the same
error.

Any help will be greatly appreciated!

Kind regards,

Xi

Mime
View raw message