ctakes-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Zuo Yiming <yiming...@gmail.com>
Subject could not find or load main class org.apache.uima.tools.cvd.CVD
Date Mon, 03 Oct 2016 20:08:53 GMT
Hi everyone,

I started to use cTAKES 3.2.2 earlier last month. It worked well on my mac.
Then I decided to migrate everything from my mac to the Windows server. I
downloaded the window version cTAKES and tried to replicate the result.
However, when I started CVD using command line (bin\runctakesCVD.bat) the
following error returns:
Error: Could not find or load main class org.apache.uima.tools.cvd.CVD

Originally, I thought this must be a general issue but after doing
extensive search on the web and spending two days on trying different
solutions, I still couldn't solve this problem. Can someone help me out?

---------------------------------
Something more to add:
1, On the web, some suggest this error occurs when UIMA_HOME is not
properly set. I wasn't using Eclipse IDE and ran cTAKES only using command
line. I doubt about this suggestion since I was doing the same thing on my
Mac and it worked fine. In addition, I don't know what UIMA_HOME should be
given the ctakes folder.
2, I did change the name of the ctakes folder from "apache-ctakes-3.2.2" to
"apache-ctakes-3.2.2-win" to distinguish the mac and the window versions
but I don't think this caused the error.

Best,
Yiming
-- 
Yiming Zuo <https://sites.google.com/site/yimingzuo/>
Georgetown U. Medical Center:
Dr. Ressom's Omics Lab <http://omics.georgetown.edu/>
ECE Department of Virginia Tech:
Computational Bioinformatics & Bio-imaging Laboratory
<http://www.cbil.ece.vt.edu/>

Mime
View raw message