ctakes-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gianfrancesco, Milena" <Milena.Gianfrance...@ucsf.edu>
Subject Re: Trouble loading AE
Date Tue, 27 Sep 2016 21:11:55 GMT
Thank you both. I just deleted everything and redownloaded in order to make sure all files
were transferred properly. I downloaded ctakes version 3.2.2, and resources version 3.2.1.1.

As outlined in the User Guide, I moved the temp resources download to the apache folder, overwriting
the previous resources folder. I confirmed that there is a folder /apache-ctakes-3.2.2/resources/org/apache/ctakes/dictionary/lookup/fast

When trying to load an UMLS AE (Aggregate Plain Text), this that I get the error message:

“org.apache.uima.resource.ResourceInitializationException: initialization of annotator class
“org.apache.ctakes.assertio.medfacts.cleartk.HistoryCleartkAnalysisEngine” failed.”

Here is the terminal output:

27 Sep 2016 13:58:32  INFO Chunker - Chunker model file: org/apache/ctakes/chunker/models/chunker-model.zip

27 Sep 2016 13:58:33  INFO ContextDependentTokenizerAnnotator - Finite state machines loaded.

27 Sep 2016 13:58:33  INFO ConstituencyParser - Initializing parser...

SFGH-0H0DHJW-DT:apache-ctakes-3.2.2 mgianfrancesco$ bin/runctakesCVD.sh

log4j: reset attribute= "false".

log4j: Threshold ="null".

log4j: Retreiving an instance of org.apache.log4j.Logger.

log4j: Setting [ProgressAppender] additivity to [false].

log4j: Level value for ProgressAppender is  [INFO].

log4j: ProgressAppender level set to INFO

log4j: Class name: [org.apache.log4j.ConsoleAppender]

log4j: Parsing layout of class: "org.apache.log4j.PatternLayout"

log4j: Setting property [conversionPattern] to [%m].

log4j: Adding appender named [noEolAppender] to category [ProgressAppender].

log4j: Retreiving an instance of org.apache.log4j.Logger.

log4j: Setting [ProgressDone] additivity to [false].

log4j: Level value for ProgressDone is  [INFO].

log4j: ProgressDone level set to INFO

log4j: Class name: [org.apache.log4j.ConsoleAppender]

log4j: Parsing layout of class: "org.apache.log4j.PatternLayout"

log4j: Setting property [conversionPattern] to [%m%n].

log4j: Adding appender named [eolAppender] to category [ProgressDone].

log4j: Level value for root is  [INFO].

log4j: root level set to INFO

log4j: Class name: [org.apache.log4j.ConsoleAppender]

log4j: Parsing layout of class: "org.apache.log4j.PatternLayout"

log4j: Setting property [conversionPattern] to [%d{dd MMM yyyy HH:mm:ss} %5p %c{1} - %m%n].

log4j: Adding appender named [consoleAppender] to category [root].

27 Sep 2016 14:03:29  INFO LvgCmdApiResourceImpl - Loading NLM Norm and Lvg with config file
= /Users/mgianfrancesco/Desktop/apache-ctakes-3.2.2/resources/org/apache/ctakes/lvg/data/config/lvg.properties

27 Sep 2016 14:03:30  INFO LvgCmdApiResourceImpl -   config file absolute path = /Users/mgianfrancesco/Desktop/apache-ctakes-3.2.2/resources/org/apache/ctakes/lvg/data/config/lvg.properties

27 Sep 2016 14:03:30  INFO LvgCmdApiResourceImpl - cwd = /Users/mgianfrancesco/Desktop/apache-ctakes-3.2.2

27 Sep 2016 14:03:30  INFO LvgCmdApiResourceImpl - cd /Users/mgianfrancesco/Desktop/apache-ctakes-3.2.2/resources/org/apache/ctakes/lvg/

27 Sep 2016 14:03:30  INFO LvgCmdApiResourceImpl - cd /Users/mgianfrancesco/Desktop/apache-ctakes-3.2.2

27 Sep 2016 14:03:30  INFO ClearNLPDependencyParserAE - using Morphy analysis? true

Loading configuration.

Loading feature templates.

Loading lexica.

Loading model:

........................................................................................

27 Sep 2016 14:03:42  INFO Chunker - Chunker model file: org/apache/ctakes/chunker/models/chunker-model.zip

27 Sep 2016 14:03:44  INFO ContextDependentTokenizerAnnotator - Finite state machines loaded.

27 Sep 2016 14:03:44  INFO ConstituencyParser - Initializing parser...


From: Bandeep Singh <bsingh@phemi.com<mailto:bsingh@phemi.com>>
Reply-To: "user@ctakes.apache.org<mailto:user@ctakes.apache.org>" <user@ctakes.apache.org<mailto:user@ctakes.apache.org>>
Date: Tuesday, September 27, 2016 at 1:21 PM
To: "user@ctakes.apache.org<mailto:user@ctakes.apache.org>" <user@ctakes.apache.org<mailto:user@ctakes.apache.org>>
Subject: Re: Trouble loading AE

If you are trying to run the AggregatePlaintextFastUMLSProcessor.xml as described by the User
guide , my best guess is that you are missing the folder /apache-ctakes-3.2.2/resources/org/apache/ctakes/dictionary/fast



On Tue, Sep 27, 2016 at 1:09 PM, Bandeep Singh <bsingh@phemi.com<mailto:bsingh@phemi.com>>
wrote:
Can you share the complete stack trace (error logs). And may be we will know what is going
on.


On Tue, Sep 27, 2016 at 12:47 PM, Gianfrancesco, Milena <Milena.Gianfrancesco@ucsf.edu<mailto:Milena.Gianfrancesco@ucsf.edu>>
wrote:
Thanks, yes, so I am getting this error message in response to loading the AE even though
resources have been downloaded as specified in the User Manuel. Any other thoughts as to why
this may be occurring? Do any of the files within the resources folder need to be modified
before loading?


From: Bandeep Singh <bsingh@phemi.com<mailto:bsingh@phemi.com>>
Reply-To: "user@ctakes.apache.org<mailto:user@ctakes.apache.org>" <user@ctakes.apache.org<mailto:user@ctakes.apache.org>>
Date: Tuesday, September 27, 2016 at 11:55 AM

To: "user@ctakes.apache.org<mailto:user@ctakes.apache.org>" <user@ctakes.apache.org<mailto:user@ctakes.apache.org>>
Subject: Re: Trouble loading AE

Hi Milena,

I am referring to the same resources mentioned in the User Install Guide doc.


-Bandeep

On Tue, Sep 27, 2016 at 11:05 AM, Gianfrancesco, Milena <Milena.Gianfrancesco@ucsf.edu<mailto:Milena.Gianfrancesco@ucsf.edu>>
wrote:
Hi Bandeep,

I downloaded resources as instructed in the User Install Guide and copied them into the resources
folder. Is that what you are referring to? Or it there another set of UMLS resources to be
downloaded? There didn’t appear to be so in the link.

Thanks

From: Bandeep Singh <bsingh@phemi.com<mailto:bsingh@phemi.com>>
Reply-To: "user@ctakes.apache.org<mailto:user@ctakes.apache.org>" <user@ctakes.apache.org<mailto:user@ctakes.apache.org>>
Date: Wednesday, September 21, 2016 at 3:54 PM
To: "user@ctakes.apache.org<mailto:user@ctakes.apache.org>" <user@ctakes.apache.org<mailto:user@ctakes.apache.org>>

Subject: Re: Trouble loading AE

Hi,
Glad that it worked !

I think resources are missing in your cTakes installation.
Did you download the UMLS resources separately from https://sourceforge.net/projects/ctakesresources/files/?source=navbar
And You have to put these resources under org/apache/ctakes/dictionary/

Hope that Helps !

Bandeep

On Wed, Sep 21, 2016 at 3:45 PM, Gianfrancesco, Milena <Milena.Gianfrancesco@ucsf.edu<mailto:Milena.Gianfrancesco@ucsf.edu>>
wrote:
Thanks, Bandeep. That seems to have solved that issue, but now when I try to load AE I get
an error message popup that states: "org.apache.uima.resource.ResourceInitializationException".
I'm not sure what this means? It only happens when I try to load the AEs that utilize UMLS.

Thanks in advance.



________________________________
From: Bandeep Singh [bsingh@phemi.com<mailto:bsingh@phemi.com>]
Sent: Tuesday, September 13, 2016 5:24 PM
To: user@ctakes.apache.org<mailto:user@ctakes.apache.org>
Subject: Re: Trouble loading AE

Hi Milena,

It looks like a classic example of Java version mismatch. One of the dependencies of cTakes
is Java 8
Please make sure you have JAVA SDK installed and not JRE. I have OpenJDK 8 running on my system
and cTakes runs fine on my system.

 -Bandeep

On Tue, Sep 13, 2016 at 2:32 PM, Gianfrancesco, Milena <Milena.Gianfrancesco@ucsf.edu<mailto:Milena.Gianfrancesco@ucsf.edu>>
wrote:
Hello,

I have just installed cTakes and followed instructions in the 3.2 User Install Guide. However,
I am unable to load an AE. I have a UMLS user name and password, and have updated the appropriate
scripts as outlined in the User Guide, yet I get this error when trying to load any AE (even
the non-UMLS ones):


Exception in thread "AWT-EventQueue-0" java.lang.UnsupportedClassVersionError: org/apache/ctakes/dependency/parser/ae/ClearNLPDependencyParserAE
: Unsupported major.minor version 51.0

at java.lang.ClassLoader.defineClass1(Native Method)

at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637)

at java.lang.ClassLoader.defineClass(ClassLoader.java:621)

at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)

at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)

at java.net.URLClassLoader.access$000(URLClassLoader.java:58)

at java.net.URLClassLoader$1.run(URLClassLoader.java:197)

at java.security.AccessController.doPrivileged(Native Method)

at java.net.URLClassLoader.findClass(URLClassLoader.java:190)

              …… + more

 I have double checked that I have the latest Java software. Any idea what could be causing
this error?

Thank you!

Milena






Mime
View raw message