ctakes-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bandeep Singh <bsi...@phemi.com>
Subject Re: Trouble loading AE
Date Wed, 21 Sep 2016 22:54:31 GMT
Hi,
Glad that it worked !

I think resources are missing in your cTakes installation.
Did you download the UMLS resources separately from
https://sourceforge.net/projects/ctakesresources/files/?source=navbar
And You have to put these resources under *org/apache/ctakes/dictionary/*

Hope that Helps !

Bandeep

On Wed, Sep 21, 2016 at 3:45 PM, Gianfrancesco, Milena <
Milena.Gianfrancesco@ucsf.edu> wrote:

> Thanks, Bandeep. That seems to have solved that issue, but now when I try
> to load AE I get an error message popup that states:
> "org.apache.uima.resource.ResourceInitializationException". I'm not sure
> what this means? It only happens when I try to load the AEs that utilize
> UMLS.
>
> Thanks in advance.
>
>
>
> ------------------------------
> *From:* Bandeep Singh [bsingh@phemi.com]
> *Sent:* Tuesday, September 13, 2016 5:24 PM
> *To:* user@ctakes.apache.org
> *Subject:* Re: Trouble loading AE
>
> Hi Milena,
>
> It looks like a classic example of Java version mismatch. One of the
> dependencies of cTakes is Java 8
> Please make sure you have JAVA SDK installed and not JRE. I have OpenJDK 8
> running on my system and cTakes runs fine on my system.
>
>  -Bandeep
>
> On Tue, Sep 13, 2016 at 2:32 PM, Gianfrancesco, Milena <
> Milena.Gianfrancesco@ucsf.edu> wrote:
>
>> Hello,
>>
>> I have just installed cTakes and followed instructions in the 3.2 User
>> Install Guide. However, I am unable to load an AE. I have a UMLS user name
>> and password, and have updated the appropriate scripts as outlined in the
>> User Guide, yet I get this error when trying to load any AE (even the
>> non-UMLS ones):
>>
>> Exception in thread "AWT-EventQueue-0" java.lang.UnsupportedClassVersionError:
>> org/apache/ctakes/dependency/parser/ae/ClearNLPDependencyParserAE :
>> Unsupported major.minor version 51.0
>>
>> at java.lang.ClassLoader.defineClass1(Native Method)
>>
>> at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637)
>>
>> at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
>>
>> at java.security.SecureClassLoader.defineClass(SecureClassLoade
>> r.java:141)
>>
>> at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
>>
>> at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
>>
>> at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
>>
>> at java.security.AccessController.doPrivileged(Native Method)
>>
>> at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
>>               …… + more
>>
>>  I have double checked that I have the latest Java software. Any idea
>> what could be causing this error?
>>
>> Thank you!
>>
>> Milena
>>
>
>

Mime
View raw message